Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've just installed feynmf package and tried working with a standard example. I'm working with MikTeX 2.9 on Windows. The compilation worked fine and I got the diagram in the PDF, but when changing the code nothing happens. It seems as if there is some problem with the rights concerning overwriting the already created diagram files.

There was another question similar to this one and the answer was simply "rerun mf after a change in a diagram".

I have already tried but I still got the same problem. I can't overwrite the already created diagram and I always get the same diagram.

The way I rerun mf is: mf "\mode=localfont; input diag1", where (of course) "diag1" is the fmffile name in .tex source.

Any suggestions?

Thank you very much!

share|improve this question
    
Welcome to TeX.SX! I suggest you feynmp instead of feynmf; using Metapost is more friendly than using Metafont. The syntax is exactly the same. –  egreg Dec 16 '13 at 21:17
    
Thank you. I loaded the feynmp package but now my compiler does not recognize the graphics extension. It finds an error in \begin{fmfgraph*}(50,30) ... –  Edoardo Dec 16 '13 at 22:11
    
Can you add a minimal working example (MWE)? –  egreg Dec 16 '13 at 22:14
    
\usepackage{feynmp} ... \begin{document} \setlength{\unitlength}{1mm} \begin{fmffile}{diag1} \begin{fmfgraph*}(50,30) \fmfleftn{i}{2} ... \end{fmfgraph*} \end{fmffile} ... I find LaTeX Error: Unknown graphics extension: .1 –  Edoardo Dec 16 '13 at 22:22
    
and the error is at the line where I wrote \begin{fmfgraph*}(50,30) –  Edoardo Dec 16 '13 at 22:22
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.