Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I try to put \textsuperscript{ère} with Roman digits everywhere in document but as I understood the command \textsuperscript{} in French makes effect for all symbols except of "è"?

This solution didn't help.

Could somebody help to fix it? Here is the code:

\documentclass[12pt]{report} 

\usepackage{fontspec}
\usepackage{xunicode}
\usepackage{xltxtra}
\usepackage[babel=false]{csquotes}
\usepackage{polyglossia}
\setdefaultlanguage{french}
\setotherlanguages{german,english,greek,polish,russian}
\setmainfont[Mapping=tex-text]{Linux Libertine}
\usepackage{setspace}

\newfontfamily\greekfont[Script=Greek,Mapping=tex-text]{CMU Serif}
\newfontfamily\russianfont[Script=Cyrillic,Mapping=tex-text]{CMU Serif}

\begin{document}

I\textsuperscript{ère}

\end{document}

And the result:

enter image description here

Thanks

share|improve this question
    
Does good old-fashioned \textsuperscript{\`ere} work? –  Seamus Apr 5 '11 at 15:42
    
@Seamus Unfortunately no. :( –  filokalos Apr 5 '11 at 15:45
1  
@filokalos please provide a minimal example since \textsuperscript{ère} and \textsuperscript{\`ere} work for me... –  Seamus Apr 5 '11 at 15:57
    
@Seamus Thank you. :) –  filokalos Apr 5 '11 at 16:35
    
@Seamus I've put the code. –  filokalos Apr 5 '11 at 18:30

2 Answers 2

up vote 5 down vote accepted

This seems to be due to the way xltxtra redefines the \textsuperscript macro: this seems to be thrown by Linux Libertine, as shown by the minimal example:

\documentclass{article} 
\usepackage{fontspec}
\usepackage{xltxtra}
\setmainfont[Mapping=tex-text]{Linux Libertine O}

\begin{document}

I\textsuperscript{ère}

\end{document}

Luckily, it can be fixed using the no-sscript option:

\documentclass{article} 
\usepackage{fontspec}
\usepackage[no-sscript]{xltxtra}
\setmainfont[Mapping=tex-text]{Linux Libertine O}

\begin{document}

I\textsuperscript{ère}

\end{document}

(I've got the font name as Linux Libertine O as on my Mac this is the file name needed to get XeTeX to actually find it.)

share|improve this answer
2  
If you read the xltxtra documentation, this issue is discussed with a different font. What's happening is that xltxtra is using real superscripts rather than the usual shrunk-and-shifted characters. However, some superscript glyphs are missing from Linux Libertine, and so only those it has end up superscript! –  Joseph Wright Apr 5 '11 at 18:39
    
It works. Thank you very much. :) –  filokalos Apr 5 '11 at 18:46

This works:

\documentclass[a4paper]{article}
\usepackage[utf8]{inputenc} % or latin1
\usepackage[T1]{fontenc}
\usepackage[french]{babel}
\begin{document}
\textsuperscript{ère}
\end{document}

Select the right encoding for your system.

share|improve this answer
    
Thank you. But I'm using \usepackage{fontspec} \usepackage{xunicode} \usepackage{polyglossia} Could you give an advise what should I do in this case? –  filokalos Apr 5 '11 at 16:36
    
@filokalos: as Seamus suggested you before, please provide a minimal example allowing us to reproduce the problem. I did a test with a document with the packages you just mentioned and couldn't reproduce your problem. –  Gonzalo Medina Apr 5 '11 at 17:07
    
@Gonzalo Medina @Seamus Sorry, I've just corrected the post. –  filokalos Apr 5 '11 at 18:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.