Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have updated my TeX distribution using MacTeX 2013 and I have now a problem on my TeX documents: The accents are not understood by Texmaker anymore.

Here is a screenshot of what I get:

enter image description here

Here is a copy of the code:

\documentclass{article}
\usepackage{times}
\usepackage{amsmath}
\usepackage{graphicx}
\usepackage[latin1]{inputenc}
\usepackage[francais]{babel}
\usepackage[mode=buildnew]{standalone}
\usepackage{subcaption}
\usepackage[a4paper]{geometry}
\usepackage{here}
\usepackage{tikz}
\usetikzlibrary{positioning}
\usetikzlibrary{matrix}

\usepackage{amsmath}
\usepackage{pgfplots}
%\pgfplotsset{compat=1.9} 

\begin{document}

J'ai tent� deux approches pour l'imagerie 3D, la premi�re consiste � d�couper le volume � imager en voxels, puis � calculer le retard de chaque antenne$(i,j)$ du r�seau de fa�on � focaliser sur la sc�ne voxel apr�s voxel. C'est une technique tr�s gourmande en temps de calcul, mais facile � comprendre.

\end{document}

It looks like an encoding problem, I have tried with UTF8 and different ISO but no way to transform those � in accents ... If I try to modify my file with accents, it works fine.

Any clue?

share|improve this question
    
You have to use the right encode on your editor. Go to preference or options or something like this and set up it. I guess that you can change it also using some button on the status bar. movingtowardslinux.files.wordpress.com/2011/01/texmaker.png –  Sigur Dec 28 '13 at 12:11
    
That's strange, I can change the encode using the preference but there is no modification in the status bar, the only way for me to change it is to modify it at the software start, when it detects a problem and suggests me to use a different encoding –  Thomas Dec 28 '13 at 12:16
    
If I'm not wrong, the status bar shows the encoding of the current file. If the editor ask about it when you open the file, choose to auto detect it. But if you change the encoding of the file by somehow, then you have to change it back. –  Sigur Dec 28 '13 at 12:28
    
I have tried to ask the encoding at the terminal using $file --mime-encoding file.tex$, I get iso 8858-1 for each files, but some works OK, some others don't ... –  Thomas Dec 28 '13 at 12:33
1  
Problem Solved ! I tried to open ISO-8859-1 files with encoding ISO-8859-4 ... I will answer my question, thanks @Sigur for your valuable help –  Thomas Dec 28 '13 at 12:41

1 Answer 1

up vote 2 down vote accepted

I finally solved my problem with the help of @Sigur. It was an encoding issue, I'll try to describe the solution hoping that it will help someone in the future ...

First of all, the encoding format of a .tex file can be checked using the following command in the terminal :

file --mime-encoding myfile.tex

And here is what i got :

myfile.tex: iso-8859-1

After my distribution and texmaker update, the default encoding format has changed to utf8. Even a decoding using "iso-8859-4" caused a problem for the accents.

The encoding format can be changed in texmaker by going in

Files -> Preferences -> Editor

and by choosing the right encoding format.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.