Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

my Debian Wheezy seems to have an old version of apacite package. A file like

\documentclass{book}
\usepackage[natbibapa]{apacite}
\begin{document}
\end{document}

will produce a message, in its log

Package: apacite 2009/03/01 v4.05 APA citation
! LaTeX Error: Unknown option `natbibapa' for package `apacite'.

Debian's apt-get says

texlive-bibtex-extra is already the newest version.

So I believe I should update it manually. I followed instructions from http://mirror.jmu.edu/pub/CTAN/biblio/bibtex/contrib/apacite/README and How can I manually install a LaTeX package (Debian/Ubuntu Linux)?

root@draper:/usr/local/share/texmf/apacite# cd ..
root@draper:/usr/local/share/texmf# mktexlsr
mktexlsr: Updating /usr/local/share/texmf/ls-R... 
mktexlsr: Updating /var/lib/texmf/ls-R-TEXLIVEMAIN... 
mktexlsr: Updating /var/lib/texmf/ls-R-TEXLIVEDIST... 
mktexlsr: Updating /var/lib/texmf/ls-R-TEXMFMAIN... 
mktexlsr: Updating /var/lib/texmf/ls-R... 
mktexlsr: Done.

But then I try to recompile and it seems that apacite was not updated.

Package: apacite 2009/03/01 v4.05 APA citation
! LaTeX Error: Unknown option `natbibapa' for package `apacite'.

Any suggestions on what else to try?


Following cfr's suggestion, I moved them following the table at http://en.wikibooks.org/wiki/LaTeX/Installing_Extra_Packages

root@draper:/usr/local/share/texmf# tree
.
├── apacite
│   └── README
├── bibtex
│   └── bst
│       └── apacite
│           ├── apacann.bst
│           ├── apacannx.bst
│           ├── apacite.bst
│           └── apacitex.bst
├── ls-R
└── tex
    └── latex
        └── apacite
            ├── apa5ex.bib
            ├── apacdoc.sty
            ├── apacite.adx
            ├── apacite.and
            ├── apacite.aux
            ├── apacite.bbl
            ├── apacite.blg
            ├── apacite.drv
            ├── apacite.dtx
            ├── apacite.dtx.old
            ├── apacite.dvi
            ├── apacite.idx
            ├── apacite.ilg
            ├── apacite.ins
            ├── apacite.ins.old
            ├── apacite.log
            ├── apacite.pdf
            ├── apacite.sty
            ├── apacite.toc
            ├── apacxmpl.tex
            ├── dutch.apc
            ├── english.apc
            ├── finnish.apc
            ├── french.apc
            ├── german.apc
            ├── greek.apc
            ├── ngerman.apc
            ├── norsk.apc
            ├── spanish.apc
            └── swedish.apc

7 directories, 36 files
root@draper:/usr/local/share/texmf# texhash
texhash: Updating /usr/local/share/texmf/ls-R... 
texhash: Updating /var/lib/texmf/ls-R-TEXLIVEMAIN... 
texhash: Updating /var/lib/texmf/ls-R-TEXLIVEDIST... 
texhash: Updating /var/lib/texmf/ls-R-TEXMFMAIN... 
texhash: Updating /var/lib/texmf/ls-R... 
texhash: Done.
root@draper:/usr/local/share/texmf# 

Trying

kpsewhich apacite

returns nothing.


Still stumped with apacite, so I decided to see other ways to solve the main problem. Main problem was how to comply with a rule in 6th edition of APA's Publication Manual regarding references to multiple author works (all authors should be cited the first time, later they can be cited as Smith et al. )

This works:

\usepackage[longnamesfirst]{natbib}
... (and assuming citations are like \citet{} and \citep{} )
\bibliographystyle{newapa}
share|improve this question

closed as off-topic by egreg, Werner, Heiko Oberdiek, Sean Allred, barbara beeton Mar 6 at 21:50

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

    
You need to install things into the correct directories. So, for example, bst files need to go in /usr/local/share/texmf/bibtex/bst/apacite and the .sty and .apc files in /usr/local/share/texmf/tex/latex/apacite and so on. You can mirror the locations used for Debian's package just in the local tree rather than the main tree. –  cfr Jan 4 at 0:45
    
Hi cfr, I tried copying the files to the right places but still it did not work. I gave up using apacite and tried something else. –  Juan Zuluaga Jan 5 at 18:06
2  
Glad you found something that worked, anyway. By the way, kpsewhich apacite is expected to find nothing as there is no file with exactly that name. kpsewhich apacite.sty should find something, though. –  cfr Jan 5 at 18:50
4  
This question appears to be off-topic because it is about a problem due to outdated software in the user's working directory –  egreg Mar 6 at 20:52

1 Answer 1

Sure enough, by following cfr suggestion of doing

kpsewhich apacite.sty 

it showed that it was using an obsolete apacite.sty left in the local working directory (why was it there? I can't remember). Deleting it did the trick.

So, yes, please make sure that your local working directory is free from .sty files that should be somewhere else.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.