Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to make TexMaker (Mac) work with biber. I, naively, tried to change the configuration of the TexMaker by replacing bibtex by biber, but of course such a primitive way of solving issues will never work.

This is the configuration line I have for BibLatex in my TexMaker Preferences:

"/usr/texbin/bibtex" %.blg

Can anybody help?

PS: I can compile and work with TexShop, but I prefer TexMaker.

share|improve this question
1  
If biber is in /usr/texbin/ then I think you want "/usr/texbin/biber" %.bcf or just "/usr/texbin/biber" %. –  Torbjørn T. Jan 10 at 14:03
    
The first option worked. Thanks. –  I-G Jan 10 at 14:45
    

2 Answers 2

up vote 3 down vote accepted

To set up biber in Texmaker, do the following. Click on User, User Commands, Edit User Commands. You can define five custom commands there. Pick one that is unused (if any) and fill it as shown below.

enter image description here

Click Ok.

The new command will then be featured in the list of available commands.

enter image description here

share|improve this answer

biber runs on a file with the file ending .bcf. In Texmaker % is used as a placeholder for the basename of the current file, so you need

biber %.bcf

if biber is in the path, or

/path/to/biber %.bcf

replacing /path/to/ with the directory where biber is located, e.g. /usr/texbin/biber %.bcf.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.