Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I get following error messages, I ran several checks, but just can't figure out where they're comming from! I use MikTex 2.9 and Biber 1.7. These are the error messages:

Line255: File ended while scanning use of \field. <inserted text> \par \begin{document}
Line92: Illegal parameter number in definition of \NewCount. <to be read again>1 \begin{enumerate}
Line92: Undefined control sequence.<argument> \blx@bbl@data \begin{enumeLine256: Incomplete \iffalse; all text was ignored after line 92. <inserted text>\fi \include{PSA4_Deckblaetter}
Line256: Incomplete \iffalse; all text was ignored after line 92. <inserted text>\fi \include{PSA4_Deckblaetter}
Line259: Undefined control sequence. \ps@plain -> \let save@@mkboth\@mkboth\ps@save@plain\let\@mkboth....
Line1: Incomplete \iffalse; all text was ignored after line 259 <inserted text>\fi <> PSA4_Globalisation_Meta.tex The file ended while I was skipping conditional text.

When I run Biber I get this message:

Entity: line 1961: parser error : Extra content at the end of the document <bcf:section number="0"> ^

I compile frequently so I know exactly that everything worked fine until I wrote a new paragraph and included 8 new references. I use a meta .tex file and then include each chapter separately as an own .tex.

What I did so far:

  • Checked my .bib file for wrong symbols or the like. Found some "&" and took them out and deleted everything else that was suspicous.
  • I ran a mininmal example using my meta file code and then ran a check on each chapter separately including ALL the references.
  • Ran another test only with the new paragraph I worte and only the new references.
  • I checked all .tex files for any overlooked \iffalse. (I had used it before to check something, but deleted it then (completely!)) and checked for lonely \begin{enumerate}.

Everything works perfectly there! But if I run my original complete document I get these errors!

I know you guys want minimal examples, but all my code, references and text works perfectly within a minimal example. So I don't know what else I need to provide you apart from the full file.

share|improve this question
    
Without seeing some code, it will be difficult for people here to diagnose your problem. That may require some effort on your part, but you need to isolate the problem first, and then post some minimal code that reproduces the error(s). –  Jubobs Jan 11 at 11:42
    
Hm. Ok. I'll try. I was hoping that someone could at least point me into a direction of where to look. –  Mary Jan 11 at 11:45
    
No! Try not. Do. Or do not. There is no try. –  Jubobs Jan 11 at 11:47
    
Sorry, but I've been doing that for the past 5 hours. If I'd know how, I would have already done it. No need to get unfriendly about it. –  Mary Jan 11 at 12:02
4  
This question appears to be off-topic because it is about a non reproducible problem –  egreg Jan 11 at 15:34
show 4 more comments

closed as off-topic by egreg, Svend Tveskæg, Jubobs, barbara beeton, Peter Jansson Jan 11 at 16:40

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

I was not able to create a minimial working example to reproduce the error. Obviously there is nothing wrong with the .tex files themselves. I deleted the "production" files in the folder, but MikTex was not able to recreate them and ran into a major error. I could not fix any of the errors, but I found another solution during my attempt (thx jubobs for making me try harder):

I moved everything to a backup folder. Copied only the .tex files back into my original folder. Renamed them. And boom! It's working perfectly! The renaming seemed to have an impact (although it does not make much sense to me).

Note: The old files in the backup folder still produce this error although they are the exact same .tex files. Guess some error must have caught iself up in one of the production files.

share|improve this answer
    
+1 for determination! –  Ethan Bolker Jan 11 at 15:40
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.