Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using MikTeX 2.9 version and although the manual says I can use LuaTeX, there is nothing in the TeXworks menu. I can see all the other members of the TeX family but none for LuaTeX.

Can someone point me as to how to configure it? I am using Windows Vista.

share|improve this question

2 Answers 2

up vote 6 down vote accepted

Open TeXworks, choose Edit -> Preferences... in the menu and go to the Typesetting tab. In the Processing tools section, click on the little + button to add a new entry. In the dialog window, you have to type in the following values:

enter image description here

Repeat this step to add LuaLaTeX:

enter image description here

Now, you will be able to choose LuaTeX/LuaLaTeX from the dropdown box next to the green button.

UPDATE
In some cases, the argument -synctex=1 may cause trouble. Try replacing it by $synctexoption in this case or leave it out completely.

share|improve this answer
    
thanks this worked well. –  alif Apr 10 '11 at 2:12

In preferences, composition, processing tools, you can add your preferred engines here in case luatex or lualatex ... For Linux it's like that and also for os x I think for windows it's the same. You can see the command line for others engines, and after you can adapt for luatex and windows. First the command line ( /home/yourname/TeXLive/bin/i386-linux/luatex) then options, $synctexoption (to sync with the pdf) and $fullname.

you can add also

%!TEX TS-program = lualatex before your code !

share|improve this answer
    
@alif I don't know if my terms are exact because I use french version –  Alain Matthes Apr 9 '11 at 14:37
1  
Adding the %!TEX ... line only works if TeXworks has been configured to use Lua(La)TeX before, as described in the first part of your answer. –  diabonas Apr 9 '11 at 14:57
1  
Ok! I have always seen $synctexoption and not --synctex=1 like in texshop is it possible to use $synctexoption ? –  Alain Matthes Apr 9 '11 at 15:11
    
It should also be possible to use $synctexoption - it differs from configuration to configuration and I've seen both possibilities. I updated my answer to include this. –  diabonas Apr 9 '11 at 19:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.