Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a problem in TeXnicCenter. So I have built the .tex file with Ctrl+F7. I have 0 errors, and now how can I generate the PDF file? That button - Build Output (F7) is disabled. Why?

When I press F5 I got the error from the image:

Error

share|improve this question
    
This seems to be a problem with the editor and not with LaTeX itself. Apparently the PDF file was generated, but TeXnicCenter can't find the viewer to open it; this suggests that something's wrong with the output profile definitions. I don't use that editor so I can't help much more in this regard. –  Gonzalo Medina Apr 9 '11 at 16:39
    
To see if the problem is the output profile in TeXnicCenter, go to the folder containing the .tex file, and see if the .pdf associated file is there (you can open it manually). –  Gonzalo Medina Apr 9 '11 at 16:46
    
yes, i see that is was generated so it's ok.. i think the problem is that the viewer (in my case Acrobat Reader 9) cannot be found.. i don't know what to do to specify the path for acrobat reader, or something else.. –  qwerty Apr 9 '11 at 16:51
add comment

4 Answers 4

up vote 4 down vote accepted

We had this problem a lot with the stable builds of TeXnicCenter, and as a result, I've never trusted Adobe Reader and DDE. It might be improved with TeXnicCenter 2.0alpha3, but when we started testing the alphas, we just pointed them all at SumatraPDF.

In our LaTeX => PDF build profile, Viewer tab:

Executable path:

C:\Program Files\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Program Files\TeXnicCenter Alpha\TeXnicCenter.exe\" /ddecmd \"[goto('%f','%l')]'\""

View project's output, DDE command:

[ForwardSearch("%bm.pdf","%Wc",%l,0,0,1)]

View project's output, Server: sumatra, Topic: control

Forward search, DDE command:

[ForwardSearch("%bm.pdf","%Wc",%l,0,0,1)]

Forward search, Server: sumatra, Topic: control

Close document before running (LaTeX): Do not close

You could greatly simplify the above if you don't need to jump back and forth between the PDF output and the source files. But the best thing about Sumatra is that you can keep it open and it will pick up on PDF changes when you rebuild. We never got our installed versions of Adobe Reader to close consistently via DDE.

TeXnicCenter build profile

share|improve this answer
    
For non-TeX code the use of <pre>...</pre> tags is recommended to avoid wrong syntax highlighting. –  Martin Scharrer Apr 9 '11 at 17:39
add comment

I think Adobe changed the name of the DDE Server name for new Acrobat Reader versions. I think you need it to be AcroViewR10 instead of acroview.

In TexnicCenter press Alt+F7 to edit the profiles. Click on Latex -> PDF, and click the Viewer tab.

share|improve this answer
    
qwerty specified in a comment that Acrobat Reader 9 is used. –  doncherry May 7 '11 at 13:17
add comment

Changing the server worked for me as well. I am using Reader 11.0.

I did the following:

  1. Build >> Define Output Profiles...
  2. Select the profile Latex->DVI->PDF and go to the "Viewer" tab
  3. Changed the server to acroviewR11 in {View project's output, Forward search, Close document before running (La)Tex}
share|improve this answer
    
Welcome to TeX.SX! You can have a look on our our starter page to familiarize yourself further with our format. –  Claudio Fiandrino Jun 27 '13 at 11:55
add comment

Hit Alt+F7 and set viewer preferences according to the example. It works with win7 and Adobe 11.

enter image description here

share|improve this answer
    
But I think the main changes are the DDE commands... for the newer versions of Adobe the option [DocClose[... thoesn't close the pdf viewer before compile and cause fatal crashing... With the option DDE [AppExit] this problem is solved and you can let your PDF open and then compile:it will close prior. –  Claudia Nov 17 '13 at 23:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.