Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I think this error starts after updating skim to the latest version.


Document 'PDFfile.pdf' not open in application LSOpenURLsWithRole() failed for the 
application /private/var/folders/O9/O9WzNPBfEsCRnERR4J07f++++TI/-Tmp-/Skim 62 
Update/B121659D-D5E2-4EF3-A582-A94789DEE5D6/Skim.app with error -10810 for the file 
PDFfile.pdf. sh: /private/var/folders/O9/O9WzNPBfEsCRnERR4J07f++++TI/-Tmp-/Skim 62
 Update/B121659D-D5E2-4EF3-A582-A94789DEE5D6/Skim.app/Contents/SharedSupport/displayline: 
No such file or directory

error number 256 opening viewer

It seems the link to the Skim.app is wrong. The Application is installed at /Applications/Skim.app and the displayline file exists at the path under the app.

I have not created anything in my setup, which has worked great for some years.

How can I change the path to Skim?

share|improve this question
    
I figured out by myself. If I deleted the tmp folder for the Skim 62 Update, the correct skim opened again. I also ran this command, to ensure that the open with path to Skim was correct locate lsregister -kill -r -all local,system, user –  Lauer Apr 11 '11 at 10:07
add comment

2 Answers

Perhaps you need to reinstall TM and Skim in the folder Applications, then verify the PATH with $echo $PATH.

I use TextMate Version 1.5.10 (1631) and Skim 1.3.13.

In Skim : enter image description here

In TextMate : advanced prefs enter image description here

In LaTeX Bundle Prefs : enter image description here

Now I use OS X 10..6.7 and all work fine with synchro etc.

Do you use the Bundle LaTeX original ? or LaTeX 2 ? and do you have change some scripts ?

Do you have update Python or Ruby ? LaTeX bundle use Python and LaTeX 2 uses Ruby !

share|improve this answer
    
I am using the standard Latex bundle, But the problem was the skim path where the update confused textmate. It works now, but I can only answer my on question after 24 hours :/ –  Lauer Apr 11 '11 at 10:08
    
Perhaps you need to remove the old prefs of Skim. It's often the simplest solution. You can delete all the folders created by Skim, Skim and the prefs of Skim. Sometimes i need to download Skim manually; because the DL fails. –  Alain Matthes Apr 11 '11 at 11:10
add comment
up vote 0 down vote accepted

I figured out by myself. If I deleted the tmp folder for the Skim 62 Update, the correct skim opened again. I also ran this command, to ensure that the open with path to Skim was correct locate lsregister -kill -r -all local,system, user

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.