Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

My document used the libertine package. My chapter titles are formatted to sans serif with \sffamily and the titlesec package. I'm assuming this means it uses biolinum font for my chapters. Now I want to change my document to lmodern but keep the biolinum chapter formatting. Since I am changing the sffamily to the lmodern variant (whatever it may be called) I need to use the \fontfamily{<internalname>}\selectfont command.

After browsing the libertine documentation and the libertine type1 .sty files I can not find the internal name for biolinum. I have tried LinuxBiolinumO-LF and this seems to work but gives a warning when combined with \bfseries, so I can not reproduce the bold formatting I had when I used sffamily under the libertine package. Any ideas on how to fix? I do not want to change the sfdefault.

Im using texlive 2012 with pdflatex. Thanks.

share|improve this question
    
Yes that will allow me to use \sffamily again. But I mentioned a restriction: want to keep lmss as the \sfdefault. Maybe I can make a new command in the pramble giving me access to 2 \sffamily versions (lmss & biolinum)? –  Jayvl Jan 21 at 16:45
    
Well, yes, haha. Is it odd to want font control in pdflatex? The whole internal naming thing is strange if you ask me. Whish I could just use {\biolinum text} to change text to that font. –  Jayvl Jan 21 at 16:51

1 Answer 1

up vote 4 down vote accepted

Actually, it is not that difficult; the problems arise more from the many options the biolinum family offers, which means there is no \biolinum command per se.

The following should allow you access to both types of sans serif:

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{biolinum}
\renewcommand{\sfdefault}{lmss}
\usepackage{lipsum}


\begin{document}

{\sffamily\lipsum[1]}

{\sffamily\bfseries\lipsum[1]}

{\sffamily\bfseries\itshape\lipsum[1]}

\newpage
{\biolinumOsF\lipsum[1]} % compare \biolinumLF

{\biolinumOsF\bfseries\lipsum[1]}

{\biolinumOsF\bfseries\itshape\lipsum[1]}

\end{document}
share|improve this answer
    
Thanks. It seems my libertine installation is a bit outdated. I can not use the biolinum package. So I tried with my \usepackage{biolinum-type1} but this does not contain any control sequence like the one you used. Guess I should update first then test again. –  Jayvl Jan 21 at 17:33
1  
It should be \renewcommand{\sfdefault}{lmss}; don't redefine \sffamily that way. –  egreg Jan 21 at 17:33
    
@Jayvl -- In my 2012 copy of biolinum-type1.sty (dated 2013/02/13), there are the following, defined by \DeclareTextFontCommand (lines 156-158): \liningnums, \biolinumOsF, and \biolinumLF. Is your copy different? –  jon Jan 21 at 18:05
    
@Jon -- Yes my copy (2012/10/30) is different, it does not even have 50 lines. –  Jayvl Jan 21 at 18:44
    
@Jayvl -- Why not install either libertine-legacy.tds.zip or libertine.tds.zip from here? The .tds.zip files are super easy to install on TeX Live: either unzip them at the base of TEXMFHOME or TEXMFLOCAL (findable via the command kpsewhich -var-value TEXMFHOME or kpsewhich --var-value TEXMFLOCAL). The .tds indicates that it will unzip everything into the appropriate directories and/or create them if these directories don't exist. –  jon Jan 21 at 18:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.