Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using the biblatex package to add citations and a bibliography to my LaTeX document. I've noticed that only the first author plus "et al." is displayed for works with more than three authors. That's fine with me for in-text-citations, but I'd rather have the complete author information in the bibliography. How can I do that?

share|improve this question
add comment

2 Answers 2

up vote 32 down vote accepted

UPDATED ANSWER: Simply set the package option maxbibnames=99 in the preamble. (There's also maxcitenames which controls the maximum number of authors displayed in citations and maxnames which may be used to change both maxbibnames and maxcitenames; the default value for all those options is 3.)

ORIGINAL ANSWER: The maximum number of displayed authors - both for in-text-citations and the bibliography - is controlled by the option maxnames (with a default value of 3). To show all authors only in the bibliography, don't change the value of maxnames in the document preamble, but use the optional argument of \printbibliography instead: Type

\printbibliography[maxnames=99]

at the place in your document where you want the bibliography to appear.

If you want all bibliographies (and lists of shorthands) in all your LaTeX documents to display the complete author information, instead of typing [maxnames=99] every time, you can add the following code to the configuration file biblatex.cfg:

\newcounter{bibmaxnames}
\setcounter{bibmaxnames}{99}
\patchcmd{\blx@printbibliography}{#1}{#1,maxnames=\thebibmaxnames}{}{}
\patchcmd{\blx@bibbysection}{#1}{#1,maxnames=\thebibmaxnames}{}{}
\patchcmd{\blx@bibbysegment}{#1}{#1,maxnames=\thebibmaxnames}{}{}
\patchcmd{\blx@bibbycategory}{#1}{#1,maxnames=\thebibmaxnames}{}{}
\patchcmd{\blx@printshorthands}{#1}{#1,maxnames=\thebibmaxnames}{}{}

Note that is a hack which uses internal biblatex commands and hopefully will be replaced by a proper package option in a later version of biblatex (the current version is 0.9b). (\patchcmd derives from the etoolbox package, which is loaded automatically by biblatex.)

EDIT: biblatex 1.1, which was released on January 5th, 2011, introduced the options maxbibnames, minbibnames, maxcitenames and mincitenames (settable in the document preamble and in the configuration file biblatex.cfg).

EDIT: biblatex 1.6, which was released on July 29th, 2011, "removed the local max/minnames and max/minitems options from \printbibliography and friends to enforce consistency. Please use the global options instead." (Release notes)

share|improve this answer
5  
+1 for coming back and updating, although I think the updates should go at the top of the post, so newcomers avoid using archaic methods. –  naught101 Oct 10 '12 at 4:36
add comment

Check the option maxnames and set it to a large value.

share|improve this answer
3  
This changes the number of names in in-text citations as well. The correct option for only setting the value in the bibliography is maxbibnames (from page 45 of the manual). Note that if you set maxbibnames before maxnames, the maxnames setting will override the maxbibnames setting. –  naught101 Oct 10 '12 at 4:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.