Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

For a few days now I was wondering why RStudio stopped showing the "Sync PDF view to editor location". I still don't know for sure, but since my .synctex.gz file is apparently "(busy)" I assume there is a connection.
I tried removing the files that are typically created upon compiling a Sweave document in the hopes that it would work then, but the new file is again called "myfile.synctex.gz(busy)". In addition, there was a "This file is currently not available for use on this computer" error but this has vanished now, so I can at least open and use my PDF again.
I've seen a similar question here, but it was never answered and since I can't comment yet, I could only ask again. Does anyone know how and why it happens, that a file can be busy according to its extension? Would it be enough to wait longer than the 10 minutes I already tried?

By the way, I'm compiling with pdfLaTeX, my PDF previewer is SumatraPDF and I've checked the "Always enable Rnw concordance" check box in RStudio.

Update!
I tried to compile a basic .Rnw file in RStudio to see if the missing synctex button is gone entirely, but it showed up fine with the minimal example. On the other hand, the .Rnw file I'm compiling without the option to use synctex afterwards is located on a server and when I compile it on another computer (from the same folder), the synctex button will also show up! Amazing.
Even better: when I run it again on my laptop now, it also works! No busy .synctex.gz file any more.

Update 2
Once I had left the network and was only working with offline files, it stopped working again. I'm blaming the Windows offline file system now.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.