Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I created a PDF using txfonts. But the base 14 fonts (Times-Roman, Times-Italic etc.) are not embedded in the PDF. Could somebody help me to solve this issue? The font information in my PDF is as given below:

 name                                 type              emb sub uni object ID
------------------------------------ ----------------- --- --- --- ---------
Times-Roman                          Type 1            no  no  no      14  0
Times-Roman                          Type 1            no  no  no      15  0
Times-Italic                         Type 1            no  no  no      16  0
LCHINT+NimbusRomNo9L-Medi            Type 1            yes yes no      17  0

In the pdfmaps.tex which I have the following entries:

\pdfmapfile{=acrobat-std-urw-kb.map}
\pdfmapfile{=psfonts.map}
\pdfmapfile{=txr.map}
share|improve this question

migrated from stackoverflow.com Apr 12 '11 at 4:46

This question came from our site for professional and enthusiast programmers.

3 Answers 3

Nowadays the base fonts are included by default. You can enable/disable this by setting pdftexDownloadBase14 true / pdftexDownloadBase14 false in updmap.cfg and then regenerate the map files. You can temporarly (at least on miktex) switch by using \pdfmapline{pdftex_dl14.map} / \pdfmapline{pdftex_ndl14.map} in your document.

But if your system is old (psfonts.map sounds old) things can be different there. At first uncomment simply the \pdfmapfile commands and look what your pdftex does as default. If it doesn't work then, you should sent informations about your tex system and version.

share|improve this answer

The PDF specification requires that a PDF viewer/printer/whatever must have the base 14 fonts embedded. Because of this, there is not need for an application to embed those fonts in a document.

http://en.wikipedia.org/wiki/Portable_Document_Format#Standard_Type_1_Fonts

share|improve this answer
1  
@Claran McHale: Certain variants of PDF, such as PDF/A, and certain printers require that all fonts be embedded, in order to be sure that the file prints exactly as desired. –  monniaux May 10 '11 at 11:01

Here a working solution:

http://www.grassbook.org/neteler/highres_pdf.html

-> 3 Embedding fonts in PDFLateX

You created your PDF document with "pdflatex" and need to deliver it to your publisher but they complain that the fonts are not embedded? There is an easy solution to this. Note that all tricks with setting "pdftexDownloadBase14" to true etc failed for me. So, simply do this:

convert to Postscript:

pdftops main.pdf main.ps

reconvert to PDF but enforce font embedding (note, hyperlinks will not survive):

ps2pdf14 -dPDFSETTINGS=/prepress -dEmbedAllFonts=true main.ps main2.pdf

verify:

pdffonts main.pdf

Now all fonts should be embedded and your publisher happy.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.