Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am new to the amsart document class. For some reasons \author (etc..) is not showing after I use \maketitle. This is my tex:

\documentclass[12pt,reqno,a4paper]{amsart}

\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{amsfonts}
\usepackage{mathrsfs} 
\usepackage{amsthm} 
\usepackage{latexsym} 
\usepackage{pictexwd}
\usepackage{pdftricks}
\usepackage{natbib}
\usepackage{setspace}
\usepackage{color}
\usepackage[affil-it]{authblk}

\begin{document}

\title{Temptation, Asymmetric information and Committment}

\author{Mark}

\affil{University of Leicester}

\date{February 2014}

\maketitle

\begin{abstract}
To be written
\end{abstract}

\section{introduction}

...

\end{document}

and this is the output: enter image description here

can anybody help me out?

share|improve this question
    
Ok, I have used package \usepackage{titling} and at least I get everything but I am sure there has to be some other way... –  Matt Jan 24 at 14:54
    
Your MWE is overly complicated many irrelevant packages. Doesn't amsart have its own system for authors and their affils? –  daleif Jan 24 at 14:58
    
I Apologise (this is actually the first time Ihear about minimal working examples) I will do better next time. –  Matt Jan 24 at 15:40

1 Answer 1

the way author information is handled by amsart is quite different from how it is handled by article, and the authblk package is based on the article conventions. this difference is what is causing the author information to be omitted.

if you really need the authors presented as they are in article (modified by authblk), then amsart is not going to work for you.

if you are willing to accept the amsart presentation, then you will also need to change \affil to \address or \curraddr. also, the facilities of amsthm are built into amsart, and amsmath and amsfonts are automatically loaded, so it's not necessary to specify those three packages with \usepackage.

share|improve this answer
    
Hello. Yes I know about amsmath and the others. Honestly I keep them there not to forget them for when I use the article document class. Can this create any conflict? As for the author issue. I am not sure I need the same output of article. I wondered if there is a way, any way, to have the authors presented in amsart as well. Not necessarily as in article (actually I do not like the article class that's why I am trying to move to amsart...) –  Matt Jan 24 at 15:37
    
the ams document classes protect against "double loading" of these packages. however, if you want to apply some option to one of the packages, it will be ignored if added with \usepackage. –  barbara beeton Jan 24 at 15:39
    
I see, ok thank you very much for this. –  Matt Jan 24 at 15:41
    
regarding author information, changing this to the style used for article would only be possible by completely redefining how the information is handled on input. that would be a major modification to the internal code of amsart.cls. there is one journal based on amsart with a more article-like topmatter block: the quarterly of applied mathematics; get the author package here. it should be easier to modify that than to start from amsart.cls itself. (please remove any ams support info if you do so.) –  barbara beeton Jan 24 at 15:53
    
I see. Thank you I will look into the package and correct this as soon as I can. –  Matt Jan 24 at 16:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.