Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Using biblatex-chicago, how can I make sure that the volume field of an @incollection entry is printed in the first citation?

My entry looks something like this:

@incollection{ei2:ibn.al.haytham:vernet,
    Author = {Vernet, J.},
    Pages = {788--9},
    Title = {Ibn al-Haytham},
    Volume = {3},
    Xref = {ei2},
    Year = {1971}}

@book{ei2,
    Address = {Leiden},
    Edition = {2},
    Publisher = {Brill},
    Shorthand = {EI2},
    Title = {Encyclopaedia of Islam},
    Volumes = {12},
    Year = {1960--2005}}

I'd like the first \cite{ei2:ibn.al.haytham:vernet} command (assuming ei2 has already been cited somewhere above) to output:

J. Vernet, “Ibn al-Haytham,” in EI2, vol. 3, pp. 788–9

or even (but this is perhaps getting too ambitious)

J. Vernet, “Ibn al-Haytham,” in EI2, vol. 3 (1971), pp. 788–9

Currently what I get is:

J. Vernet, “Ibn al-Haytham,” in EI2, 788–9

which is not good, since it ignores the volume number.

I call biblatex-chicago in my preamble like this:

\usepackage[notes,
    backend=biber,
    mincrossrefs= 1,
    noibid,
    doi= false,
    eprint= false,
    url= false,
    usetranslator= true,
    abbreviate= true,
    uniquename= true
]{biblatex-chicago}

MWE

test.tex

%!TEX TS-program = xelatex
%!TEX encoding = UTF-8 Unicode

\documentclass[12pt,article,oneside,letterpaper]{memoir}
\usepackage{geometry}
\usepackage{amsmath}
\usepackage{gensymb}
\usepackage{latexsym,amssymb,amsfonts}
\usepackage{graphicx}
\usepackage{ulem}
\usepackage{varioref}
\usepackage{xltxtra,fontspec,xunicode}
\usepackage{classics}
\usepackage{ifthen}
\usepackage[american]{babel} 
\usepackage{csquotes}


\setromanfont[Mapping=tex-text]{Palatino}
\setsansfont[Scale=0.80,Mapping=tex-text]{Arial}
\setmonofont[Scale=0.70,Ligatures=NoCommon]{Courier New}


\usepackage[    notes,
        backend=biber,
        mincrossrefs = 1,
        noibid,
        doi=        false,
        eprint=     false,
        url=        false,
        usetranslator=  true,
        abbreviate= true,
        uniquename= true
    ]{biblatex-chicago}
\bibliography{test.bib}

\begin{document}

First time citation: \cite{ei2:ibn.al.haytham:vernet}


Second time citation (of a different article in the same book): \cite{ei2:tabari:bosworth}

\end{document}

test.bib

%% This BibTeX bibliography file was created using BibDesk.
%% http://bibdesk.sourceforge.net/


%% Created for Alex at 2014-01-28 21:28:36 +0200 


%% Saved with string encoding Unicode (UTF-8) 



@book{ei2,
    Abstract = {I:  1960
V:  1986},
    Address = {Leiden},
    Date-Added = {2014-01-28 19:28:22 +0000},
    Date-Modified = {2014-01-28 19:28:22 +0000},
    Edition = {2},
    Publisher = {Brill},
    Shorthand = {EI2},
    Title = {Encyclopaedia of Islam},
    Year = {1960--2005}}

@incollection{ei2:ibn.al.haytham:vernet,
    Author = {Vernet, J.},
    Date-Added = {2014-01-28 19:28:22 +0000},
    Date-Modified = {2014-01-28 19:28:22 +0000},
    Notetoself = {III (1971) 788--9},
    Pages = {788--9},
    Title = {Ibn al-Haytham, Abū ʿAlī…},
    Volume = {3},
    Xref = {ei2},
    Year = {1971}}

@incollection{ei2:tabari:bosworth,
    Author = {Bosworth, C. E.},
    Date-Added = {2014-01-28 19:28:22 +0000},
    Date-Modified = {2014-01-28 19:28:22 +0000},
    Keywords = {Tabari},
    Pages = {11--15},
    Shorttitle = {al-Ṭabarī},
    Title = {al-Ṭabarī, Abū DJafar Muḥammad b.\ DJarīr b.\ Yazīd},
    Volume = {10},
    Xref = {ei2},
    Year = {2000}}

The output I get

First time citation: J. Vernet, “Ibn al-Haytham, Abū ʿAlī...,” in Encyclopaedia of Islam, 2nd ed., vol. 3 (Leiden: Brill, 1960–2005), 788–9, (hereafter cited as EI2).

Second time citation (of a different article in the same book): C. E. Bosworth, “al-Ṭabarī, Abū DJafar Muḥammad b. DJarīr b. Yazīd,” in EI2.

What I'd like to get

First time citation: J. Vernet, “Ibn al-Haytham, Abū ʿAlī...,” in Encyclopaedia of Islam, 2nd ed. (Leiden: Brill, 1960–2005) (hereafter cited as EI2), vol. 3 (1971), 788–9.

Second time citation (of a different article in the same book): C. E. Bosworth, “al-Ṭabarī, Abū DJafar Muḥammad b. DJarīr b. Yazīd,” in EI2, vol. 10 (2000), 11–15.

Or something like that. What I'm most interested in is being able to depend on the volume number appearing in the citation even when I use a normal \cite command and not \volcite.

(But as one reader kindly pointed out, it may be a problem with my software versions, since I have not updated yet to TeXLive 2013.)

Update: new MWE with TeXLive 2013

Now I've updated to TeXLive 2013 (and updated all packages using TeX Live Utility). The situation is different, but not resolved. I used precisely the same MWE as above, except that I added \printshorthands \printbibliography to test.tex right before \end{document}.

Now, curiously, the "shorthand" I defined for ei2 (Shorthand = {EI2}) is ignored for the inline citations...

MWE output using TeXLive 2013

share|improve this question
    
What version of biblatex/biblatex-chicago are you running (it's 2.8/0.9.9d over here)? I get the output "J. Vernet, ‘Ibn al-Haytham’, in Encyclopaedia of Islam, 3:788–9" if EI2 was cited before, and "J. Vernet, ‘Ibn al-Haytham’, vol. 3 (1971), 788–9" if it was not (I do realise though that neither of those outputs is what you want). Also it would be really helpful if you could provide a full (compilable) MWE. –  moewe Jan 27 at 17:41
    
Sorry for the dumb question, but how can I check what version of biblatex-chicago I'm using? In any case, that may well be the problem, since I haven't yet updated to TeXLive 2013. (I hesitate because almost everything is working so well, so I'm afraid to change things, but I should probably move on.) Meanwhile, I've put together a full MWE, in case that is of help (I'll post it in a moment). –  Alex Roberts Jan 28 at 19:27
    
The question is not dumb at all. Version 0.9.9d (beta) is what the documentation on my machine says on the title page (you can find it in the doc\latex\biblatex-chicago folder, the README in the folder also identifies the version as version 0.9.9d, 2013-10-30). In biblatex-chicago.style we find biblatex-chicago.sty,v 0.1.1.53 2013/10/29 14:10:24, while in chicago-notes.bbx it's v 0.9.7.50 2013/10/29 12:32:21. An update on your part might help us provide a solution we know works (we can test it) even if it does not resolve the problem in itself. –  moewe Jan 28 at 20:02
    
Now that I have updated to 2013, my version is also 0.9.9d (beta). As I have continued to work, I have noticed that in this new version, it consistently renders my bibtex entries which make use of the xref field incorrectly. Reading through the new documentation (biblatex-chicago.pdf §10, p.127), I am wondering if this new problem is due to changes made to the package (which have the result of not using the xrefed entry's Title field as the @incollection's Booktitle). I have played around with the two new options booklongxref and longcrossref, with no success so far. –  Alex Roberts Jan 30 at 6:35
    
biblatex-chicago.pdf, p.84: "Please also note that the combination of shorthand, reprinttitle, and/or userf fields with shortened cross references may produce unexpected results, at least as biblatex-chicago-authordate currently stands. I advise caution before doing so." I'm not using authordate, but could this nevertheless explain the problem, since I am using xref and shorthand at the same time? It used to work so well, with only a few minor quirks (my original question in this post was about one of these quirks, namely a problem with how the volume field was treated). –  Alex Roberts Jan 30 at 8:12
show 2 more comments

1 Answer

This is only a partial answer to the question, which I owe to the author of biblatex-chicago, David Fussner. It is partial because my question ended up being about two separate issues:

  1. a problem using Shorthand with volume numbers and xref

  2. a problem with @incollection entries xref'd to @book entries in the new version of TeXLive (2013).

This is an answer to #2. To fix #2, I changed all xref entries to crossref entries. That still didn't quite work, since @incollection entries were not inheriting a @book's title as a booktitle field, which is necessary to make the first citation of the @incollection entry appear with its book's title. For that, David Fussner provided me the following code, which he tells me may be incorporated into the next release of biblatex-chicago:

\DeclareDataInheritance{book}{incollection}{%
  \inherit{title}{booktitle}
  \inherit{subtitle}{booksubtitle}
  \inherit{titleaddon}{booktitleaddon}
  \noinherit{shorttitle}
  \noinherit{sorttitle}
  \noinherit{indextitle}
  \noinherit{indexsorttitle}
}

With this in the preamble, running TeXLive 2013, and using crossref (not xref) fields, my citations come out looking great. This solution even improves the situation with part #1 of my question, because now @incollection entries in multivolume books are printing their volume field on the first citation. What hasn't been quite resolved is how the shorthand with crossref works, since now the first time an article in the book is cited, the book's whole title appears, but without the phrase "hereafter cited as..."; the good news is that further citations of articles from the book use the book's shorthand!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.