TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using the itemize environment with the enumitem package, and one of the issues I'm having is that the itemize environment seems to create a newline, or at least add vertical spacing at the end of the environment.

How can I suppress this newline?

share|improve this question
Are you looking for Inline lists?? – Vineet Menon Jun 8 '12 at 7:45

The list-like environments (enumerate, itemize, and description) add a vertical space equal to \topsep + \parskip + (possibly) \partopsep before and after the list. You can suppress those spaces using the corresponding enumitem keys; an example:



  \item First.
  \item Second.

share|improve this answer
This appears to be be right, but I don't believe enumitem allows you to define parsep. Adding a \setlength\parsep{0pt} inside the itemize environment didn't seem to solve things. How can I set the value of parskip for only the itemize environment? – Varun Madiath Apr 12 '11 at 22:00
@Varun Madiath: you can change the value using the parsep key, as in \begin{itemize}[topsep=0pt,parsep=0pt]. You can kill all extra vertical space with the nolistsep option. – Gonzalo Medina Apr 12 '11 at 22:42
My apologies, I was referring to parskip in my earlier comment. How can I set the parskip for the itemize environment. – Varun Madiath Apr 12 '11 at 23:12
@Varun Madiath: the value of \parskip inside itemize is controlled by the parsep key of enumitem; however, you can always change it manually by adding something like \setlength\parskip{10pt} inside itemize, just before the first \item command. – Gonzalo Medina Apr 13 '11 at 0:25
@Varun Madiath: If the problem with the list persists, please add a minimal working example to your original question, illustrating the problem. – Gonzalo Medina Apr 13 '11 at 0:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.