Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'd like to know if someone ported the bibliography styles used in revtex 4.1 (like apsrev4-1.bst) so they can be used in other classes, like book.

Thanks in advance!

share|improve this question
    
I just did a test using the book class with \bibliographystyle{apsrev4-1} and everything worked OK. Have you had any problems? –  Gonzalo Medina Apr 13 '11 at 1:10
1  
I get some errors when compiling after running bibtex, like this: (./main.bbl (./main.brf)) Runaway argument? \BibitemOpen \bibfield {author} {\bibinfo {author} {\bibfnamefont {R.\ETC. ! File ended while scanning use of \BR@@lbibitem. <inserted text> \par l.166 \bibliography{tex/references} –  Elton Carvalho Apr 13 '11 at 1:32
add comment

2 Answers 2

up vote 9 down vote accepted

It looks if the revtex bst's are highly customized for for the class file. I have found that the following gives more or less the same output with a standard class

\usepackage[sort&compress,numbers]{natbib}
\bibliographystyle{apsrev4-1}
\usepackage{doi}%<----------
\usepackage{hyperref}

It also needs an additional bibtex file with a custom setup especially if you want the full article names included (the longbibliography option in revtex4-1). Create the following file, say revtex-custm.bib with contents

@CONTROL{REVTEX41Control}
@CONTROL{apsrev41Control,author="00",editor="1",pages="1",title="0",year="0"}

Define your bib then as follows:

\bibliography{my-bib-file, revtex-custm}
share|improve this answer
    
Thanks, In order to make it work the way you described, I had to comment out hyperref and load nohyperref, but the whole reason I wanted apsrev are the nice liks pointing to the online versions of the paper. Also, removing hyperref also removed all the links and bookmarks in the file, which is undesired. Apparently, all the customization in the class file is responsible for making the links work. With hyperref enabled, I get the same arror as in my comment above. If anyone knows of a bibligraphy style that makes the journal name and volume a link to its DOI, please let me know. –  Elton Carvalho Apr 13 '11 at 13:33
    
@Elton Carvalho: I have added the doi package and activated hyperref. This seems to do what you are asking –  Danie Els Apr 13 '11 at 14:38
1  
Thanks, man. Now it worked. I found out that the problem was in my .bib file. ISI Web of Knowledge generates dome weird bibliography entries with double braces for years and volumes and apsrev.bst doesn't swallow that very well. –  Elton Carvalho Apr 13 '11 at 19:09
2  
I appreciate the demonstration of @control in your answer but there are several subtle points that caused me problems. 1) You need to "cite" "apsrev41Control" somehow to make sure that the @CONTROL block gets processed, and 2) title="-1" will fail to disable the titles (for reasons I do not understand yet, title=-1 will work...). If you know how to fix these simply, could you ammend your answer? (Perhaps I should ask another question, but your answer is so close...). Thanks. –  mforbes Dec 21 '11 at 11:24
add comment

I haven't been able to make the @CONTROL sequences work as above, but I found a way to tweak apsrev4-1.bst to output what you want. First, copy apsrev4-1.bst to a new file named, for example, apsrev4-1_custom.bst, and put it in the same directory as your tex file. In it, find the function control.init, and modify any options you'd like -- #0 is false, #1 is true. To get the titles to display, change the #0 above control.title to #1. Use this newly modified by running \bibliographystyle{apsrev4-1custom}.

share|improve this answer
    
Thanks, I'll try this in my next document! –  Elton Carvalho Sep 17 '12 at 19:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.