Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to draw LFG f-structure matrices using the avm package (https://www.essex.ac.uk/linguistics/external/clmt/latex4ling/avms/).

For some reason my avm objects do not respect the \\ command, causing obvious problems.

Some sample code that fails to produce multi-line matrices.

\documentclass[11pt]{scrartcl}

\usepackage{array}
\usepackage{avm}
\begin{document}

\begin{avm}
  \[one\\ two\\ \]
\end{avm}


\end{document}

Which produces something like

enter image description here

share|improve this question
    
Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. –  Andrew Swann Feb 2 at 10:09

2 Answers 2

up vote 4 down vote accepted

The old version of avm.sty does not work with the array package. You need to update to version 1.03 available from http://nlp.stanford.edu/cmanning/tex/ . With this version your sample code produces the expected output:

enter image description here

Here is the list of file versions I used:

 *File List*
scrartcl.cls    2013/12/19 v3.12 KOMA-Script document class (article)
scrkbase.sty    2013/12/19 v3.12 KOMA-Script package (KOMA-Script-dependent basics and keyval usage)
 scrbase.sty    2013/12/19 v3.12 KOMA-Script package (KOMA-Script-independent basics and keyval usage)
  keyval.sty    1999/03/16 v1.13 key=value parser (DPC)
scrlfile.sty    2013/12/19 v3.12 KOMA-Script package (loading files)
tocbasic.sty    2013/12/19 v3.12 KOMA-Script package (handling toc-files)
scrsize11pt.clo    2013/12/19 v3.12 KOMA-Script font size class option (11pt)
typearea.sty    2013/12/19 v3.12 KOMA-Script package (type area)
     avm.sty    
   array.sty    2008/09/09 v2.4c Tabular extension package (FMi)
 ***********
share|improve this answer
    
For me it produces errors. I had to change \begin{avm} \[one\\ two\\ \] \end{avm} to \begin{avm} [one\\ two ] \end{avm} –  Marco Daniel Feb 2 at 10:11
    
@MarcoDaniel I've added a list of file versions for comparison. –  Andrew Swann Feb 2 at 15:46

I accepted Andrew's answer as it worked for the example I posted. Later however I ran into other package conflicts with avm, even with the newer version. I discovered that another solution to the problem is to use the tex style of linebreak \cr instead of \\.

So another way around this problem is to instead use an expression like the one below.

\begin{avm}
  \[one\cr two\cr \]
\end{avm}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.