Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using the bibliography style "plain", which in a Technical Report, formats "Technical report" in roman font. However, my publishers want "Technical Report" to be capitalised, and in italics. How can I do this?

Thanks!

share|improve this question
    
Maybe I missed something but can't you hack the default plain.bst file (that you would put in your current working directory or a known tex directory), or directly use makebst? –  chl Apr 14 '11 at 7:37
    
I probably could - if I knew how... But I'm running out of time and can't afford the time to learn how to do it right now. I was hoping somebody could simply tell me what to do! –  Alasdair Apr 14 '11 at 8:13
1  
Done it! In the block FUNCTION {format.tr.number} I changed { "Technical Report" } to { "{\em Technical Report}" }. –  Alasdair Apr 14 '11 at 8:34
    
You mean you just want \em or \em + small caps? For the former, you can run latex makebst, follows the default options but when comes TECHNICAL REPORT NUMBER: choose i (Tech. report and number italic as {\it Tech. Rep. 123'}) -- that will update FUNCTION {techreport} {...} with a line looking like format.tr.number emphasize output.nonnull. –  chl Apr 14 '11 at 8:54
2  
Please post your comment as an answer and accept it, to help others searching the site. –  Joseph Wright Apr 20 '11 at 15:14
add comment

1 Answer

(Originally posted as a comment by Alasdair)

Done it! In the block FUNCTION {format.tr.number} I changed { "Technical Report" } to { "{\em Technical Report}" }.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.