Sign up ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to use the multimedia package in Beamer to play a local, non-embeded, video. The file compiles without errors; however, when I click on the place-holder image, it simply moves to the next slide. The MWE can be seen below, and the files can (tex, image, and video) can be downloaded here:

\title{Video in Beamer presentation}
    \frametitle{\textit{Sintel} trailer 480p MP4}
        {\includegraphics[width=\textwidth]{sintel.jpg}}{sintel.avi} \\
        Click on picture to play the movie

Does this work for anyone? I am not sure if maybe my PDF viewer (evince, Ubuntu) is not compatible, or if I am just using the multimedia package incorrectly? I found the example online and assumed it worked for the author.

While other packages can embed movies/animations easily, they often require the use of Adobe Acrobat and result in very large PDFs. My motivation for using the multimedia package is to avoid using Adobe Acrobat.

Edit: I included mp4 and avi versions of the video and tried both, but no luck.

share|improve this question

2 Answers 2

up vote 6 down vote accepted

You'll need to use Okular, and not Evince. With Okular, the example you provided works as it should.

share|improve this answer
Well that was easy. Thanks! – Blink Feb 5 '14 at 19:28

I'm using LuaTeX to generate the PDf, Version beta-0.79.1 (TeX Live 2014) (rev 4971) and \usepackage{multimedia} with beamer. And with this version it's is possible to embedded *.avi and *.mp4 formats (I tested) in conjunction to the latest PDF viewer OKULAR. Possibly the error is related with the codec behind the video. This are the codec properties that works:

MP4 Codec: H.264

AVI Codec: ITU H.264

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.