Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

any latex code I want to view in TexWorks 0.4.5 r.1280 (Miktex 2.9) won't show the syntax highlighting. It compiles just fine but everything line is written in black. On very long documents the highlighting shows for several seconds then the program freezes for short and the highlighting disappears again. Windows compatibility modes did not improve the situation. Does anyone have an idea what's going wrong here?

share|improve this question
    
When the situation is, like you tell it in your comment to Harish's answer, then it is very probably an OS related issue and therefore off-topic on this site. –  Speravir Feb 7 at 20:40

1 Answer 1

Go to FormatSyntax Coloring. In the list that appears, most probably you have None selected. Select LaTeX as in the following screen shot:

enter image description here

Bingo!

share|improve this answer
    
Thank you, but as I said, its does not work. I know how to switch it on. But that has no effects. Did you use win 8.1 for the screenshot? –  harald01 Feb 7 at 18:07
    
It did work for me on both Windows 8.0 and 8.1. (I'm using TeX Live distribution though, which I highly recommend.) –  Vochmelka Feb 8 at 17:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.