Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using Texstudio 2.6.4, Miktex 2.9, Biber 1.8 and Biblatex 2.9 on Win7x64. I switched from Natbib to Biblatex as I want to use some of the better citation options in my thesis. I kept getting error messages and have read through all entries that are out there without finding a solution to this problem: Whenever there is more than 1 citation I get an error message. See the following MWE:

\documentclass[onecolumn,a4paper,12pt, oneside, openright]{report}
\usepackage[english]{babel}
\usepackage{csquotes}
\usepackage[natbib=true, style=authoryear, hyperref=true, backend=biber]{biblatex}
\addbibresource{test.bib}
\begin{document}

\input{chapter1}

\printbibliography

\end{document}

Whith Chapter 1 looking like this:

\onehalfspace
\chapter[Introduction]{Introduction}
\chaptermark{Introduction}

\section{Section1}

Text \autocite{test1}. Text \autocite{test2}.

When I compile using pdflatex biber pdflatex pdflatex I get the following error message from Biber:

Process started: "C:/Program Files (x86)/MiKTeX 2.9/miktex/bin/biber.exe" "Thesis"

INFO - This is Biber 1.8
INFO - Logfile is 'Thesis.blg'
INFO - Reading 'Thesis.bcf'
WARN - Warning: Found biblatex control file version 2.6, expected version 2.5
INFO - Found 3 citekeys in bib section 0
INFO - Processing section 0
INFO - Looking for bibtex format file 'M:/PhD/Documents/Latex/Thesis/Export2.bib' for section 0
INFO - Found BibTeX data source 'M:/PhD/Documents/Latex/Thesis/Export2.bib'

Process exited with error(s)

And the citations in the document look like the code (test1, test2) and no bibliography has been created. I assume it has to do with the line:

WARN - Warning: Found biblatex control file version 2.6, expected version 2.5

Yet this line does not make sense as I use biblatex version 2.9. In addition, if I delete the second citation there is the same warning message but it compiles just fine:

INFO - This is Biber 1.8
INFO - Logfile is 'Thesis.blg'
INFO - Reading 'Thesis.bcf'
WARN - Warning: Found biblatex control file version 2.6, expected version 2.5
INFO - Found 2 citekeys in bib section 0 
INFO - Processing section 0
INFO - Looking for bibtex format file 'M:/PhD/Documents/Latex/Thesis/Export2.bib' for  section 0
INFO - Found BibTeX data source 'M:/PhD/Documents/Latex/Thesis/Export2.bib'
INFO - Overriding locale 'English_United States.1252' default tailoring 'variable = shifted' with 'variable = non-ignorable'
INFO - Sorting 'entry' list 'nyt' keys
INFO - No sort tailoring available for locale 'English_United States.1252'
INFO - Writing 'Thesis.bbl' with encoding 'ascii'
INFO - Output to Thesis.bbl
INFO - WARNINGS: 1

Process exited normally

The citation is correct and a bibliography has been created. So maybe that warning message is not right? Any help would be greatly appreciated!

share|improve this question
1  
The warning does indeed make sense (the biblatex control file (bcf) versions are not the same as the biblatex versions; version 2.5 for bcf corresponds to version 2.8 in biblatex, 2.6 to 2.9). Your version of biblatex and Biber do not match: biblatex v 2.8 requires Biber 1.8, while version 2.9 of biblatex needs Biber 1.9. So either update Biber to 1.9 or downgrade biblatex to 2.8. –  moewe Feb 7 at 15:04
1  
Also strange: Biber says it found 3 or 2 citekeys, but you used 2 or 1. Could you try and put everything into one single MWE that is directly compilable? And please check the versions again, biblatex 2.9 is not yet released. –  matth Feb 7 at 17:50

1 Answer 1

Here is a MWE that you can use as test case, it does compile fine on my computer.

\documentclass[]{article}
\listfiles % will put version info to .log file
\usepackage[autostyle]{csquotes}
\usepackage[backend=biber]{biblatex}
\addbibresource{biblatex-examples.bib}
\usepackage[]{hyperref}
\hypersetup{colorlinks=true}

\begin{document}
Lorem ipsum dolor sit amet~\cite{kastenholz}.
At vero eos et accusam et justo duo dolores et ea rebum~\parencite{sigfridsson}.
\printbibliography 
\end{document}

You should check which versions of biblatex and biber you have installed. Compare them to the versions MiKTeX has online: biblatex and biber.
As described in another question MiKTeX uses two trees for the packages, the admin tree and the user tree. Unfortunately, biber is in the admin tree and biblatex is in the user tree by default. So in order to avoid incompatible versions of these two, you shoudl either put both into the admin tree or always update both trees.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.