Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I was using the default Ubuntu texlive package (plus extras) but it has really outdated versions, and I had to manually download newer versions, texhash, search dependencies, etc.

I'm now using TexLive 2013 to handle packages, but my system is in a sorry state, with packages both in /usr/share/texmf-texlive/ (from my previous install) and /usr/local/texlive/2013/texmf-dist (from my current install). Is there a safe way to clean it? I've already removed the apt texlive package, but these files are still there.

More simply, is there a way to point Kile to the new package location? I've already set the PATH variable to point to /usr/local/texlive/2013/bin/i386-linux. However, I can't find where to configure it to search in another place.

share|improve this question
1  
Have you restarted the computer since installing TexLive 2013? –  David Z Feb 9 at 0:56
    
@DavidZ No, I didn't, but I did try to run Kile from a fresh terminal that already had the new PATH in its environment. I'll give it a try, can't do harm. –  Bruno Kim Feb 9 at 1:00
    
@DavidZ Unfortunetely, it didn't work. I have a new package in .../texlive/2013/texmf-dist that is not present in .../texmf-texlive, and the file won't compile. –  Bruno Kim Feb 9 at 1:06
3  
Files under /usr/share/texmf-texlive/ are either orphaned or (more likely) installed by you package manager. To clear them, you need to figure out which packages they belong to and uninstall those. Your package manager should have an option to help you figure out whether any package 'owns' the files or not. In Kile, open the Konsole part and use echo $PATH to check that it is picking up your PATH correctly. –  cfr Feb 9 at 1:52

1 Answer 1

up vote 2 down vote accepted

Solved it! Adding the following entry in ~/.bashrc, Kile was able to find the newly installed packages.

TEXMFDIST="/usr/local/texlive/2013/texmf-dist"
export TEXMFDIST

Note that you must restart the computer if you launch Kile from the graphic interface. It will work if you launch it from a fresh terminal, because it'll already have the new environment variable.

share|improve this answer
1  
This is one possible fix, but not the only way, because on my system (Kubuntu) TEXMFDIST is not set but I don't have any trouble finding packages. I'm not sure offhand of the details though. –  David Z Feb 9 at 1:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.