Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am required to insert the word Appendix before the letter A in my dissertation Table of Contents as follows:

Appendix A (title for appendix A)

but the latex thesis cls file: FAU Thesis Class I use generates only the letter A followed by the appendix title:

A (title for appendix A)

The thesis cls file defines a "backmatter" command and the appendix is treated as a chapter.

\newcommand\backmatter{\appendix
\def\chaptermark##1{\markboth{%
\ifnum  \c@secnumdepth > \m@ne  \@chapapp\ \thechapter:  \fi  ##1}{%
\ifnum  \c@secnumdepth > \m@ne  \@chapapp\ \thechapter:  \fi  ##1}}%
\def\sectionmark##1{\relax}}

Is there a simple fix to the above code that will add the word Appendix before the letter A in the TOC for Appendix A? Some related questions have been posted but the answers did not appear to work in this case.

share|improve this question
1  
Can you add a link to the thesis class itself? –  Alan Munn Apr 17 '11 at 1:19
    
I've found this link stackoverflow.com/questions/5690679/… which pretty much answers the question. –  niels Jul 12 '12 at 11:38
add comment

1 Answer 1

up vote 11 down vote accepted

Add the following to your preamble:

\usepackage[titletoc]{appendix}
\makeatletter
\renewcommand\backmatter{
    \def\chaptermark##1{\markboth{%
        \ifnum  \c@secnumdepth > \m@ne  \@chapapp\ \thechapter:  \fi  ##1}{%
        \ifnum  \c@secnumdepth > \m@ne  \@chapapp\ \thechapter:  \fi  ##1}}%
    \def\sectionmark##1{\relax}}
\makeatother

The appendix package adds some extra functionality for dealing with appendices. This extra functionality (including the one you need) is accessed by using the \appendices environment instead of the \appendix command. So changing your thesis class \backmatter command to remove the \appendix command, along the with [titletoc] option of the package (which appends the appendix name to the letter in the TOC) should solve your problem.

Now in your actual thesis tex file you should do the following:

\backmatter
\begin{appendices}
\chapter{An appendix}
...
\end{appendices}
\bibliography{}
share|improve this answer
    
The suggestion worked except that now the word "Appendix" also appears in front of Bibliography as well. –  Carey Apr 17 '11 at 3:09
    
No, it shouldn't. I've edited my answer from the very first one I posted. Try the code again with the current version of the answer. I.e. make sure that the redefined \backmatter command does not contain any kind of \appendix command. (And remove your aux files.) –  Alan Munn Apr 17 '11 at 3:17
    
Works like a charm! Thank you for your help!! –  Carey Apr 17 '11 at 4:55
    
@Carey For others, you should still add a link to the actual class file. –  Alan Munn Apr 17 '11 at 4:56
    
I had a similar goal but didn't have \backmatter (\appendix instead)defined in my .cls so I tried to changed \backmatter to \appendix. It gave "Appendix" before the chapter names but I lost the lettering and it returned to numbering like the regular chapters. Instead I was able to \usepackage[title,titletoc]{appendix} and then insert \appendices before the appendix chapter headings. I assume this is a more general solution? or maybe I just got lucky. –  Dominik Apr 25 '11 at 18:52
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.