Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm not quite into this Latex yet, and I have a bit of a problem.. My preamble looks like this:

\documentclass[a4paper,article]{memoir}
\usepackage[utf8]{inputenc} \usepackage[danish]{babel} \usepackage[T1]{fontenc}
\usepackage{amsmath,amssymb} \usepackage{bm} \usepackage{amsthm} \usepackage{mathtools}
\usepackage{listings}
\usepackage{siunitx}
\usepackage{graphicx}

Every time I get to the second page, the left margin on the PDF increases. When I've managed to write enough to fill 3 pages, the margin on the third page moves back to normal. So I only have this problem on the second page. Can anybody help?

share|improve this question
2  
Welcome to the site! This sounds like a binding offset convention- if you have a look at a (paper copy) of a text book, you might notice that the margins are different for odd and even pages. –  cmhughes Feb 12 at 17:29
    
Expanding on @cmhughes comment: In most circumstances this is a desired feature - not an error. –  Hans-Peter E. Kristiansen Feb 12 at 19:03
    
@Hans-PeterE.Kristiansen I have my doubts about this claim. Articles are usually typeset with equal margins at least prior to final typesetting for publication. I would never use unequal margins for submission to a journal, for example. –  cfr Feb 13 at 1:57
    
@cfr: You are correct. -I should have specified that the feature is for books(memoir is used for books and larger works). I just wanted the OP to know that it is not an error. –  Hans-Peter E. Kristiansen Feb 13 at 10:17
add comment

2 Answers

Use a onesided document:

\documentclass[a4paper,article,oneside]{memoir}
share|improve this answer
    
Thank you! That helped. –  Louise Feb 13 at 7:32
add comment

To expand a little on Herbert's answer, what may be confusing is that memoir's documentation says this:

article typesetting simulates the article class, but the \chapter command is not disabled. Chapters do not start a new page and chapter headings are typeset like a section heading. The numbering of figures, etc., is continuous and not per chapter. However, a \part command still puts its heading on a page by itself.

Now when you use LaTeX's standard article class with

\documentclass{article}

oneside is default. To make an article two-sided, you have to specify the twoside option.

memoir, it seems, does things a little differently since the documentation also states that

The defaults among the printing options are twoside, onecolumn, openright, and final.

where these apparently apply even when the article option is passed to the class. So there is some inconsistency in describing this option as 'simulating the article class' and then not including the difference in printing defaults among the caveats.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.