Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am on a mac and I believe I am using MacTeX. I am getting errors of the sort:

File `fullpage.sty' not found.

When I run locate fullpage.sty I get

/usr/local/texlive/2013/texmf-dist/tex/latex/preprint/fullpage.sty

But when I run kpsewhich fullpage.sty I get nothing. I have already tried sudo texhash and sudo mktexlsr to no avail. I think the problem may be that I have two conflicting TeX Live versions installed—I recently installed QuTIP and I think during the process a basic version was installed via macports—but of this I am not certain. I have no idea how to proceed.

I have two questions: How can I get LaTeX to find fullpage.sty? And, if someone can see the real cause of the above error or knows how to find it, how can I remedy the situation?

share|improve this question
1  
There should be a pane in System Preferences to choose your active TeX Distribution. Please check its setting. –  Crissov Feb 13 at 13:36
    
Hi Crissov. Thank you for your reply. In the TeX Distribution pane only one option is shown: TeXLive-2013. Underneath it reads: “Full TeX Live 2013 Distribution.” This option has two suboptions ‘Intel 64’ or ‘Universal’. Unfortunately, selecting neither suboption solved my problem. Plowman. –  P. Plowman Feb 13 at 13:43
1  
You can check what your system thinks it should search with kpsewhich --var-value TEXMFMAIN (works on Linux, at least). The command returns this line for me: /usr/local/texlive/2013/texmf-dist –  jon Feb 13 at 14:51
    
Hi jon. kpsewhich --var-value TEXMFMAIN returns /opt/local/share/texmf-texlive. It seems this is wrong? Should I get /usr/local/texlive/2013/texmf-dist? –  P. Plowman Feb 13 at 14:56
    
(If you use @<name> that person gets pinged.) Sounds odd given where your fullpage.sty file is. Have you set your paths correctly? If I issue echo $PATH, one of the items returned is an item that corresponds to the output of which kpsewhich. (Note: I'm only operating on the assumption that Macs mimic *nix setups on this sort of stuff; seems like it does, but someone else should know better the degree of overlap.) –  jon Feb 13 at 18:08

1 Answer 1

up vote 1 down vote accepted

Old question, but this is a common problem. If you installed via MacTeX, TeX Live will end up in /usr/local/texlive, but I believe MacPorts installs under /opt by default (it did last time I checked, but it's been a few years). Hence, you do indeed have two conflicting TeX distributions, and you're running kpsewhich from the MacPorts install. If you enter which kpsewhich in Terminal, it probably points to /opt/local/bin/kpsewhich or something similar.

The easiest way to fix this is to edit your PATH environment variable so that /usr/texbin comes first. If you're using bash, your ~/.bash_profile, you would have something like

PATH=/usr/texbin:/opt/local/bin:/usr/bin:…:/foo/bar/bin

Alternately, if macports sets your PATH by sourcing a script in ~/.bash_profile, as Fink does (or did), you can add a final line to your profile of

PATH=/usr/texbin:$PATH

A couple of notes:

  • this will not affect PATH settings for any GUI applications, only programs launched from a shell
  • for a TeX Live not installed via MacTeX, you'd use the appropriate full path, e.g., /usr/local/texlive/2013/bin/x86_64-darwin instead of /usr/texbin
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.