Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

First post here. Hope it's not ignorant.

I am using Texmaker on Ubuntu 12.10 with PDFlatex. I am running a 64-bit machine. Fresh install of Linux and Texmaker, I am quite used to Texmaker, not sure why I am getting this error. I am able to compile other documents, so (to my knowledge) is not necessarily texmaker.

Here is my log file:

This is pdfTeX, Version 3.1415926-1.40.10 (TeX Live 2009/Debian) (format=pdflatex 2014.2.14)  14 FEB 2014 18:18
entering extended mode
 %&-line parsing enabled.
**"Book Corrections for Dr.tex"

! Emergency stop.
<*> "Book Corrections for Dr.tex"

*** (job aborted, file error in nonstop mode)


Here is how much of TeX's memory you used:
 3 strings out of 495061
 126 string characters out of 1182621
 45108 words of memory out of 3000000
 3282 multiletter control sequences out of 15000+50000
 3640 words of font info for 14 fonts, out of 3000000 for 9000
 28 hyphenation exceptions out of 8191
 0i,0n,0p,1b,6s stack positions out of 5000i,500n,10000p,200000b,50000s
!  ==> Fatal error occurred, no output PDF file produced!

I am attaching relevant parts of my file:

\documentclass[12pt,letterpaper]{article}
\usepackage[utf8]{inputenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage[left=2cm,right=2cm,top=2cm,bottom=2cm]{geometry}
\author{Jeffrey Wubbenhorst}
\title{Book Errors}
\usepackage [english]{babel}
%\usepackage [autostyle, english = american]{csquotes}
%\MakeOuterQuote{"}
\usepackage{listings}
\usepackage{color}

\definecolor{dkgreen}{rgb}{0,0.6,0}
\definecolor{gray}{rgb}{0.5,0.5,0.5}
\definecolor{mauve}{rgb}{0.58,0,0.82}

\lstset{
  language=Python,
  aboveskip=3mm,
  belowskip=3mm,
  showstringspaces=false,
  columns=flexible,
  basicstyle={\small\ttfamily},
  numbers=none,
  numberstyle=\tiny\color{gray},
  keywordstyle=\color{blue},
  commentstyle=\color{dkgreen},
  stringstyle=\color{mauve},
  breaklines=true,
  breakatwhitespace=true
  tabsize=3
}
\begin{document}

\maketitle
\section*{Introduction}
I really appreciate this book, and am honored to help contribute to it. Here are most of the errors I have found. Hopefully, this will help bring the book one step closer to publication. 

Thanks!
\section*{Python}
\begin{itemize}
\subsection*{Recurring}
\item One recurring error in code examples is the {\tt print} option, which often does not contain parentheses. 
\subsection*{c3}

\item Page 7/9: ``...  $\vee$ (simQ):..." I think there's a forgotten $\backslash$.
\subsection*{c6}
\item Page 13: ``...copy ofeach element..."
\item Page 13: ``...range iterator ylelds up the integers 0-9..."
\item Page 18: ``...function in Pyton 2, but.." 
\item Page 20: ``I will walk through a collection, such as a list, because listss, strings and tuples
all have built in iterators that walk throug them in order.."
\item Page 21: Example does not run- perhaps the author meant to define k? Possible code is shown below:
\begin{lstlisting}
>>> groceries = ["milk", "eggs", "caviar", "foie gras"]
>>> k=0
>>> while k <= 4:
... print groceries[k]
... k += 1
\end{lstlisting}

does not run straight out of the box. 


\end{itemize}

\end{document}

Thanks for any help you can offer.

share|improve this question
3  
Hi! Welcome to TeX.SX! I think the question is quite fine :) Well, you can have a look at our starter guide to familiarize yourself further with our format ;) However, these questions are usually difficult to answer. It seems from the log that the filename contains spaces, have you tried to rename the file to something simpler? –  yo' Feb 14 at 23:44
    
Drop to the command line and compile in NOT non-stop mode to find the error. That log is just telling you there is one. It isn't telling you what it is. Though not having spaces in filenames is always a good thing. Your code compiles fine here (without spaces in the filename). I'm actually surprised. I didn't know you could throw subsections around with that kind of abandon but it compiles fine. The other thing is that you have a very outdated version of TeX Live. Current is 2013 so you have a 4-version-old installation. –  cfr Feb 14 at 23:59
    
@cfr You're right- it DOES compile! Thanks for spaceless filename suggestion, that did the trick. –  Qu0rk Feb 15 at 0:08
    
@cfr Thanks for update suggestion, I will get new version. Old version is from standard Ubuntu repository. Would you repost your solution as an answer so we can upvote it? –  Qu0rk Feb 15 at 0:09
    
Done. Though I think @tohecz should really get some of the credit (maybe all of it - I just ran the code). –  cfr Feb 15 at 0:21

1 Answer 1

up vote 5 down vote accepted

As tohecz suggested, eliminating spaces from the filename solves this problem. Once the file is named appropriately, the code compiles fine:

code from question compiled as-is in suitably-named file

If the problem persisted, the best strategy to start with would be to drop to the command line so that you can compile in NOT non-stop mode. That would hopefully tell you what the error is and/or where it is rather than simply telling you that there is one.

Failing that, commenting parts of the code (e.g. packages loaded) until you don't see the error can help to narrow down the problem.

If you need to compile newer documents, you may need a more current version of TeX Live. One way to do this is to uninstall the version installed with your package manager and to install TeX Live 2013 directly from upstream instead. Instructions are available on TUG's site or in this question.

share|improve this answer
2  
It's fine, pal :) –  yo' Feb 15 at 0:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.