Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've tried to write this into a .tex file and in the same folder in which this file is put, I've added a bibli.text file.

.tex file's code

\documentclass{article}

\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[francais]{babel}


\begin{document}

J'insère le premier \cite{Uml}.

\bibliography{bibli} % mon fichier de base de données s'appelle bibli.bib

\end{document}

bibli.bib file's code :

@book{Uml,
    author    = {P. Roques et F. Vallée},
    title     = {De l’analyse des besoins à la conception},
    journal = {UML en action},
    edition  = {Quatrième},
    publisher = {Eyrolles},
    date      = {01/03/2007},
    location   = {France},
    pages     = {381},
    }

To build this, I've :

  • compiled for 2 times.
  • Build > BibTex.
  • compiled for 2 times.

OS : Windows

Edit : That in the the Outline the full structure of the BibTex file is putted by the compiler. I've no error message while compiling but The bibliography written into my bibli.tex is not included in the pdf file result.

share|improve this question
2  
You're surely missing a \bibliographystyle command; try adding \bibliographystyle{plain} before \bibliography{bibli} –  egreg Feb 15 at 10:32
    
I've not error message while compiling but The bibliography written into my bibli.tex is not included in the pdf file result. –  dgs Feb 15 at 10:34
    
What does the bibli.blg say (this is the .log file for bibtex)? –  Bernard Feb 15 at 10:44
    
Regardless of the problem I'd advise to migrate to »biblatex« and Biber as back-end. –  Thorsten Donig Feb 15 at 10:46
    
@Bernard, I'ven't found that file in the folder in which bibli.tex is putted. –  dgs Feb 15 at 10:49
show 6 more comments

2 Answers 2

up vote 2 down vote accepted

A migration to »biblatex« with Biber as back-end is suggestive. That would also solve the language issue in the bibliography items. Note that you have to do the corresponding settings in your editor in order to make it run Biber instead of BibTeX (or run Biber manually).

\documentclass[11pt,francais]{article}
\usepackage[T1]{fontenc}
\usepackage{selinput}
\SelectInputMappings{
  agrave={à},
  eacute={é}
}
\usepackage{babel}
\usepackage[babel]{csquotes}
\usepackage[backend=biber]{biblatex}

\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@book{uml,
  author    = {P. Roques and F. Vallée},
  title     = {De l’analyse des besoins à la conception},
  journal   = {UML en action},
  edition   = {4},
  publisher = {Eyrolles},
  date      = {2007-03-01},
  location  = {France},
  pages     = {381}
}
\end{filecontents*}

\addbibresource{\jobname.bib}

\begin{document}
  J'insère le premier \cite{uml}.

  \printbibliography
\end{document}

The date field of the database entry has been reformatted in order to comply the demands. Further customization of the bibliography style is of course possible.


enter image description here

share|improve this answer
    
The »filecontents« package and its corresponding filecontents* environment are only used here to make the example self-contained. They should not appear in the actual document. –  Thorsten Donig Feb 15 at 11:07
1  
Thanks for your response, but, this wouldn't work, here is the pdf file result –  dgs Feb 15 at 11:14
    
@user3289501: Obviously it works (for me). You seem to do something wrong. Did you run Biber correctly? Do you get error messages or warnings? Do you have an up-to-date TeX system? –  Thorsten Donig Feb 15 at 11:27
    
How do I to download Biber, please ? –  dgs Feb 15 at 11:34
    
@user3289501: It should be part of your TeX system. Hence no need for download. –  Thorsten Donig Feb 15 at 11:35
show 4 more comments

This code compiles perfectly for me. Note that I encoded everything in utf8, including the.bib file, as Biber understands this encoding. If you use JabRef to write your database, you can ask it thatsave in utf8 format.

I also corrected some of the field: the entry is book, and the journal field has no meaning. Actually UML 2 in action is the (main) title and "De l’analyse des besoins à la conception" is the subtitle. Also the format of the date field is yyyy-mm-dd (with hyphens, not slashes – as must be written in french, btw); but I think it's irrelevant for a book, and I replaced it with the yearfield. I gave first names in full, should you change your mind for their formatting; the firstinits option takes care of printing the short form.

Main file code:

\documentclass[11pt, a4paper, twoside]{article}

        \usepackage[utf8]{inputenc}
        \usepackage[T1]{fontenc}
        \usepackage{lmodern}

        \usepackage[francais]{babel}

        \usepackage[autostyle]{csquotes}
        \usepackage[backend = biber, style = numeric, firstinits]{biblatex}
        \addbibresource{bibli.bib}

        \begin{document}

        J'insère le premier \cite{Uml}.

        \printbibliography

        \end{document}

.bib code:

        % This file was created with JabRef 2.9.2.
        % Encoding: UTF8

        @BOOK{Uml,
          title = {UML 2 en action},
          publisher = {Eyrolles},
          year = {2007},
          author = {Roques, Pascal and  Vallée,  Franck},
          pages = {381},
          edition = {4},
          location = {France},
          subtitle = {De l’analyse des besoins à la conception}
        }

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.