Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Not sure if this problem is due to remote computer access. I am trying to run MikTex remotely. Never done that before. I was trying to convert an ipython file .ipynb to latex using Pandoc.

When I opened the latex file it created using MikTex and tried to make changes to it, the editor responds only to the first typed keypad entry and for the next ones it repeats the key. That is if I type 'Miktex', it prints in the editor 'MMMMMM'.

I thought it was due to pandoc screwing up MikTex configuration. So I uninstalled Pandoc, uninstalled MikTex and reinstalled MikTex. But I still encounter the same problem.

Now I wonder if this is some remote access issue? However, for all other non latex files the keyboard works. I can open text files and write remotely. Only MikTex has this issue.

I tried to access the remote computer using Linux machine and also Windows machine. But this issue persists. Can someone please help? Thanks

share|improve this question
    
Not sure how many MikTex people there are here. Maybe it would better fit in a MikTex IRC-channel/mailing list/forum, as it is highly specific. –  canaaerus Feb 16 at 16:59
1  
You mention opening a file in MiKTeX, which is impossible, since MiKTeX is a collection of programs, not a specific program. Elsewhere you mention an editor: which editor are you using? –  ChrisS Feb 17 at 1:38
    
First I assume you used TeXworks, that comes preinstalled with MiKTeX. Second this seems to me not related to teX & Friends, but an issue of your remote connection, and so off-topic here. –  Speravir Feb 17 at 1:46
    
It is MikTex that I use (that is the website from where I downloaded latex). It is the TexWorks editor that I open. I think it is TexWorks issue (some unicode or font issue). I can open notepad, wordpad, DOS shell or any other program and type in with my remote keyboard and everything types well. But when I open a tex file (TexWorks) and when I type in anything, the first key repeats. The only way to change the letter at times is by typing with the Shift key pressed. If it is just remote issue why does it only affect Tex editor? –  gujax Feb 17 at 3:41
    
Solved Temporarily: When I press Alt key and then type in any other key, TexWorks editor faithfully prints the characters. If Alt key is not pressed, it repeats first typed key for every subsequent keys - does not matter which key is typed in. And this happens only for TexWorks editor. tested Notepad, DOS, emacs, Windows R editor, Octave shell, Word, Wordpad all work fine. I am still accessing remotely and I think this has to do with some remote keybindings with Tex. –  gujax Feb 17 at 13:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.