Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

i made a Code for alerting through a frame.

It adds an empty (just looks empty very light text) frame in front of the greyed out frame (Picture below).

It only appears to add a frame, if i use Column Layout. Any ideas to get rid of this "redundant" frame?

\subsection{H263 / MPEG-4 Teil 2}
\begin{frame}[<+-| alert@+>]{H263 / MPEG-4 Teil 2}
\begin{columns}
    \column{.55\textwidth}
            \begin{itemize}
                \item Weiterentwicklung Richtung H261
                \item Webvideos
                \item Sorenson Spark Format
                \item H\"ohere Aufl\"osung
                \item DVD
                \item .3gp, .avi
                \item Project Mayo (DivX)
            \end{itemize}
    \column{.45\textwidth}
            \includegraphics[width=150pt]{divx.jpg}
\end{columns}
\end{frame}

Alert Image

EDIT: Maybe there is a way to add alert statement to column?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

The overlay specification for the frame is picked up both by columns and the itemize, so you get that extra slide. You can prevent this by subtracting 1 to the beamerpauses counter when the itemize begins:

\documentclass[demo]{beamer}

\begin{document}

\begin{frame}[<+-| alert@+>]{H263 / MPEG-4 Teil 2}
\begin{columns}
    \column{.55\textwidth}
            \begin{itemize}\addtocounter{beamerpauses}{-1}
                \item Weiterentwicklung Richtung H261
                \item Webvideos
                \item Sorenson Spark Format
                \item H\"ohere Aufl\"osung
                \item DVD
                \item .3gp, .avi
                \item Project Mayo (DivX)
            \end{itemize}
    \column{.45\textwidth}
            \includegraphics[width=150pt]{divx.jpg}
\end{columns}
\end{frame}

\end{document}

The demo option for beamer simply replaces actual figures with black rectangles; do not use that option in your actual document.

share|improve this answer
    
Also works to have "[<+-| alert@+>]" after the itemize of the left column, but your version is better ;) –  Stefan Sprenger Feb 16 at 23:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.