Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to use unicode-math in XeLaTeX to use Asana Math in a beamer presentation, but I am unable to use select the font for letters in math mode. See the following MWE:

\documentclass{beamer} 
\usefonttheme{serif}

\usepackage{unicode-math}
\setmainfont{Linux Libertine O}
\setmathfont{Asana Math}
%\setmathfont[range=\mathit]{Asana Math} % has no effect

\begin{document}
\begin{frame}
    Maths font test:
    \begin{itemize}
    \item math letters display in Libertine: $abcdefghijklmnopqrtuvwxyz$
    \item math operators and blackboard letters display in Asana Math: $\int_{-\infty}^{+\infty} \sum \mathbb{E}$
    \end{itemize}
\end{frame}
\end{document}

Which results in the following:

enter image description here

The letters are displayed in Linux Libertine, instead of Asana Math. I tried to tinker with the range option in unicode-math (as documented in the manual), to no avail.

Strangely, when I compile the document as an article, I get the results I expect. Am I missing something?

share|improve this question

1 Answer 1

up vote 5 down vote accepted

use

\documentclass{beamer} 
\usefonttheme{serif}
\usefonttheme{professionalfonts}%  don't change fonts inside beamer

\usepackage{unicode-math}
\usepackage{libertine}
\setmathfont{Asana Math}
...
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.