TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am searching for an editor which is capable to jump between lines in PDF view and source view, even if the document is split into multiple files. In my case I have a master, witch defines the general format and than a batch of files including the chapter with \include.

I actually tried Texmaker: I was glad with it but does not offer the wanted feature.

I tried with Gedit and its latex plugins, but Gedit keeps to crash if I even dare to open a child file.

So, is there actually a (open source) solution (for Linux/Ubuntu)?

share|improve this question
WinEdt + Sumatra work for me, but this is not Linux bundle. I believe that exist similar combination, i.e. Sumatra + some editor work on the same way. – Zarko Feb 21 '14 at 2:47
Have you looked at something like Kile's project feature? (With Okular as viewer, say.) – cfr Feb 21 '14 at 2:56
Go to LaTeX Editors/IDEs, look for editors with Synctex. and test some. BTW: When you used Texmaker you could also take a look on TeXstudio. – Speravir Feb 21 '14 at 3:00
TexStudio is awesome IMHO. – Nicholas Hamilton Feb 21 '14 at 3:23
Texmaker can help you to get forward/backward sync between .pdf and .tex for master and child files for sure. if you have -synctex=1 option activated by pdflatex -synctex=1 -interaction=nonstopmode %.tex in texmaker configuration and "Define Current document as Master Document" by going to Texmaker Options menu, you should see forward/backward interaction between .pdf and source (.tex) and vice-versa. – texenthusiast Feb 21 '14 at 3:48
up vote 5 down vote accepted

Texmaker does that out of the box like all the editors which support synctex (the synchronization is made by synctex) : just declare the "root" file as the "master document" (Options) and don't use spaces or special characters in the name of the file.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.