Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I get the following error while compiling and the pdf is also not generated properly:

ERROR: Package pgfkeys Error: I do not know the key '/tcb/library/most' and I am going to ignore it. Perhaps you misspelled it.

The code which I compiled is available here as the accepted answer: LaTeX errors in Formatting

I am using emacs for compilation.

share|improve this question
1  
May be you have to install/update tcolorbox –  Harish Kumar Feb 21 at 14:07
1  
If you use \tcbuselibrary{listings,breakable} instead of \tcbuselibrary{most} are you able to compile? –  Harish Kumar Feb 21 at 14:09
    
Saw the comment just now sir, Yes I am able to compile now with this change \tcbuselibrary{listings,breakable}.Sorry for the late reply –  subham soni Feb 21 at 14:53

1 Answer 1

up vote 4 down vote accepted

According to tcolorbox documentation:

enter image description here

It seems, tcolorbox is trying to load some libraries that aren't there in your system. As for this particular code, you need only listings and breakable library, you can try to load only them by

\tcbuselibrary{listings,breakable}

instead of \tcbuselibrary{most}.

But the better solution is to update the tcolorbox package to the newest version.

share|improve this answer
    
The last version of the folder tcolorbox (containing tcolorbox.sty) can be downloaded at ctan.org/pkg/tcolorbox and is put there (on a MAC) /Library/texmf/tex/latex. –  SDrolet Apr 20 at 13:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.