Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a problem with ligatures in LuaLaTeX when using the font Adobe Minion Pro. The fi ligature displays fine but is neither searchable nor copiable. If I copy it, I get some Asian character.

Minimal example:

\documentclass[]{scrartcl}

\usepackage{fontspec}
\usepackage{xunicode}

\setmainfont[]{Minion Pro}

\begin{document}
fi ff tt
\end{document}

Any idea on how to fix this?

Edit: This seems to be a persistent Windows problem. Fonts seems to get mixed-up for an unkown reason and it seems that this is not only happening on my machine. See my last comments to egreg's answer.

Edit2: No Windows problem as it also happens on Kubuntu 13.10. This problem might be reproducible with the 4 Minion Pro OTFs from the Adobe Reader package (Linux .deb version but other versions should be concerned too) and using TeXLive 2013 from DVD (not updated). Can anybody try this out? I suspect it's a TeX bug, possibly something with LuaTeX.

Edit3: It's the TeXLive 2013 version from DVD without update. I updated it and the problem is gone.

share|improve this question

closed as off-topic by Guido, Svend Tveskæg, Speravir, Jesse, Peter Jansson Feb 23 at 23:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center." – Guido, Svend Tveskæg, Speravir, Jesse, Peter Jansson
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Are you using an OpenType font? I cannot reproduce this problem on my system. –  Paul Gessler Feb 21 at 23:40
    
Yes it's an OpenType font. It reads version 2.108. I'm using TeXLive 2013 and TeXstudio on a Windows 7 computer. The problem occurs when I'm copying from Adobe Acrobat 10. These are the symbols I get by copying: "昀ff tt" –  Psychic Birdy Feb 21 at 23:45
    
If I copy it including the formating, I get: "昀i ff tt" –  Psychic Birdy Feb 21 at 23:51
    
If you use the polyglossia-package (recommendable), there are different language-specific Options. If those are switched on, "| disables the ligature at this Position. f"|i f"|f. But I dont have the problem: this is the copy-paste from my PDF: fiel auffahrt ... –  Christof Feb 21 at 23:52
    
From a Windows 7 PC: SumatraPDF: fi ff tt; Adobe Reader 10.1.9: fi ff tt; Adobe Acrobat Pro 10.1.4: fi ff tt. –  Paul Gessler Feb 21 at 23:53

2 Answers 2

This is what I get when compiling your example (by the way, loading xunicode is not required), copying from the PDF viewer and pasting here

fi ff tt

The Minion Pro font I'm using is the one in Adobe Reader.

Here's a picture where the characters have been selected:

enter image description here

The viewer is Skim, but also Adobe Reader gives the expected result.

Here's an example of search:

enter image description here

So, no problem.

Here's the font version information:

Version 2.110;PS 2.000;hotconv 1.0.68;makeotf.lib2.5.35818

share|improve this answer
    
@Christof The problem is not in disabling ligatures. –  egreg Feb 21 at 23:52
    
Indeed, I would like to retain the ligatures while being able to search and copy them. –  Psychic Birdy Feb 21 at 23:53
    
I know, but just in case ... BTW, did you try another font? Edit: Seems a Problem with Minion Pro. SumatraPDF: ?el auffahrt Acrobat XI: 􀄕el auffahrt. fi doesnt work, ff does (Windows 8). –  Christof Feb 22 at 0:01
    
I tried Arno Pro (also with ligatures) and it copies fine. So it's specific Minion Pro. "Version 2.110;PS 2.000;hotconv 1.0.68;makeotf.lib2.5.35818" is a newer version. Where is this from? Some bundle? –  Psychic Birdy Feb 22 at 0:07
1  
Well, seems I'm not the only one with this problem. Look at the manual for selnolig: ctan.math.utah.edu/ctan/tex-archive/macros/luatex/latex/… The abstract reads "Other f-ligatures, such as fb, fh, fj and fk, are suppressed globally", copy-paste: "Other f-ligatures, such as 昀, 昀, fj and fk, are suppressed globally" –  Psychic Birdy Feb 23 at 15:55

This is some kind of bug. It's not the OS or the font version. It's the TeXLive 2013 version from DVD without update. I updated it and the problem is gone. The bug also showed up in MacTeX 2013, see Mico's comment on egreg's answer.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.