Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I used this code for my thesis

\documentclass [12pt,oneside,final]{book}
\usepackage[left=35mm,top=26mm,right=26mm,bottom=15mm]{geometry}
\raggedbottom

It shows acceptable white space in bottom of the page at the PDF viewer but when I

print it out it looks too large!

any idea

share|improve this question
1  
Perhaps the PDF viewer thinks your paper size is different than your actual paper size. The other possibility I've seen happen is that, in Windows, the print driver can be told to "shrink to fit" which will screw up margins, too. The proper setting is "print actual size". –  Steven B. Segletes Feb 23 at 1:14
    
@StevenB.Segletes i used SumatraPDF . how can i adjust that? –  khaled Feb 23 at 1:15
    
I am only familiar with the Adobe reader, so sorry. –  Steven B. Segletes Feb 23 at 1:16
    
@StevenB.Segletes i can change it to Adobe –  khaled Feb 23 at 1:18

2 Answers 2

up vote 7 down vote accepted

The page size of the document is letterpaper, the default for the standard classes. If you want to generate a page layout for A4 paper, it must be explicitly set:

\documentclass [a4paper,12pt,oneside,final]{book}
\usepackage[left=35mm,top=26mm,right=26mm,bottom=15mm]{geometry}

or

\documentclass [12pt,oneside,final]{book}
\usepackage[a4paper,left=35mm,top=26mm,right=26mm,bottom=15mm]{geometry}

Remarks:

  • The standard classes (article, report, book) contain:

    \ExecuteOptions{letterpaper,...}
    

    Therefore the default page layout is assigned for this paper size.

  • A different matter is the media size of the document whicht the output driver generates. Unfortunately neither the LaTeX kernel nor the standard classes tell the paper size to the output driver. Without information the output driver has to use its default.

    However there are packages such as geometry, hyperref, drivers for graphics/color that provide the service telling the output driver the media size. Internally it is done by a \special or by setting special registers \pdfpagewidth, \pdfpageheight.

  • In this case, the class has executed the default option letterpaper, package geometry has told this paper size to the output driver program to generate a document with this paper size. But the result was finally printed on A4 paper with a smaller width and larger height. Therefore setting the right option is the right answer.

share|improve this answer
    
Also, I read somewhere that it is recommended to pass a4paper as a class option, like language specifications. So the first is probably preferable. –  cfr Feb 23 at 3:09
1  
@cfr: See the edited answer with the remarks. geometry has used letterpaper just because the class has set this paper size. The default for the standard classes cannot be configured, it is always letterpaper. –  Heiko Oberdiek Feb 23 at 4:38
    
Sorry. You are right. But what then is the point of being able to configure the size via tlmgr? What does that setting affect? –  cfr Feb 23 at 17:10
    
@cfr: The default for the engines is set and used for lazy documents that do not tell the output driver the page size. –  Heiko Oberdiek Feb 23 at 17:16

If you have zeniko's version of SumatraPDF (you can find it on his site, typing Ctrl+D twice will show the dimension of the page and the list of the fonts used in the document. I don't think it's a problem with the pdf viewer (it reads the page format in the document) but most probably your printer is configured for a format that's different from your .pdf.

As you didn't specify any paper format in you preamble, it probably produces a letter paper format (8.5in × 11 in, or 215.9 mm × 279.4 mm), so if your printer settings are for a4paper (8.27 in × 11.69 in or 210 mm × 297 mm), your printed page will look weird.

share|improve this answer
    
Sorry for my duplicate answer. I wrote it rather leisurely, and posted it without checking an answer was posted meanwhile. –  Bernard Feb 23 at 2:06
    
Alas, site is down ITM. –  Speravir Feb 23 at 2:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.