Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am having some issues with XeLaTeX, Biblatex, and American English in Polyglossia. According to the Biblatex manual, it uses polyglossia to determine the variant style of english and sets the style accordingly. However, this is not occurring for me. American English has successive citations as Ibid. and not Ibidem. In the following MWE, when compiled with xelatex (and biber), the second footnote is Ibidem. When compiled with pdflatex (and biber), the second footnote is Ibid.

\documentclass[letterpaper,12pt]{article}

\usepackage{iftex}
\ifXeTeX
  \usepackage{fontspec}
\fi
\ifPDFTeX
  \usepackage[american]{babel}
\fi
\usepackage{fullpage}
\usepackage[top=1in, bottom=1in, left=1in, right=1in]{geometry}
\ifXeTeX
  \usepackage{polyglossia}
  \setmainlanguage[variant=american]{english}
\fi
\usepackage[doublespacing]{setspace}
\usepackage[style=historian,     % Loads the Historian files
        backend=biber,
        sorting=nty,         % Sorts bibliography by name, title
        autocite=footnote,   % Autocite command generates footnotes
        mincrossrefs=1,      % Includes all x-ref'ed entries in the bibliography
        usetranslator=true,  % Translator's name may be substituted for
                             % author or editor, if the latter are blank
        printnoterefs=false, % Do not print "see note" short shortened notes
        printseries=true]    % Options provided by Historian, see below
        {biblatex}

\addbibresource{bib1.bib}

\begin{document}

This is a reference to a footnote.\footcite[1]{Book}. This should be an Ibid.\footcite[2]{Book}

\end{document}

The contents of bib1.bib are:

@book{Book,
   author    = {John Smith},
   title     = {A book with a very long title to make sure that it wraps around to a second line},
   address   = {1600 Pennsylvania Ave},
   publisher = {Good Books Press},
   year      = "2014"
}

It is possible that this is an issue with the Historian package for biblatex, but that just uses biblatex's settings, according to its documentation.

share|improve this question
1  
I can't get that to compile at all without error. It is complaining about an undefined command in the historian style, I think. (\SetCiteCommand.) –  cfr Feb 24 at 3:57
    
Interestingly, if one uses the standard styles with a recent version of biblatex, one seems to get "ibid." all the way. –  moewe Feb 24 at 7:28
    
@moewe -- I assume this is because biblatex-historian is older than the abbreviate option in standard biblatex. –  jon Feb 24 at 7:30

1 Answer 1

up vote 1 down vote accepted

I can't really test your example file due to how old biblatex-historian is. (I have version 0.4, which is from 2010, which is 'ancient' given how actively biblatex and biber are being developed.)

As @cfr noted, the package relies on (I believe) an old and no longer used command, \SetCiteCommand. I need to disable the command to get your example file to run; then I do get the XeTeX-related problem you describe, which is easy to work around by adding abbreviate=true to your biblatex load options. Here's a complete example:

\documentclass[letterpaper,12pt]{article}
\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@book{Book,
   author    = {John Smith},
   title     = {A book with a very long title to make sure that it wraps around to a second line},
   address   = {1600 Pennsylvania Ave},
   publisher = {Good Books Press},
   year      = 2014,
}
\end{filecontents*}

\usepackage{iftex}
\ifXeTeX
  \usepackage{fontspec}
\fi
\ifPDFTeX
  \usepackage[american]{babel}
\fi
\usepackage{fullpage}
\usepackage[top=1in, bottom=1in, left=1in, right=1in]{geometry}
\ifXeTeX
  \usepackage{polyglossia}
  \setmainlanguage[variant=american]{english}
\fi
\usepackage[doublespacing]{setspace}
\newcommand\SetCiteCommand[1]{}%           <--- ADDED; you may need to remove this line
\usepackage[
        abbreviate=true, %                 <--- ADDED
        style=historian,     % Loads the Historian files
        backend=biber,
        sorting=nty,         % Sorts bibliography by name, title
        autocite=footnote,   % Autocite command generates footnotes
        mincrossrefs=1,      % Includes all x-ref'ed entries in the bibliography
        usetranslator=true,  % Translator's name may be substituted for
                             % author or editor, if the latter are blank
        printnoterefs=false, % Do not print "see note" short shortened notes
        printseries=true]    % Options provided by Historian, see below
        {biblatex}

\addbibresource{\jobname.bib}

\begin{document}

This is a reference to a footnote.\footcite[1]{Book}. This should be an Ibid.\footcite[2]{Book}

\end{document}

Here's the relevant output from \listfiles:

biblatex.sty    2013/11/25 v2.8a programmable bibliographies (PK/JW/AB)
biblatex2.sty    2013/11/25 v2.8a programmable bibliographies (biber) (PK/JW/AB)
historian.dbx
blx-compat.def    2013/11/25 v2.8a biblatex compatibility (PK/JW/AB)
biblatex.def    
standard.bbx    2013/11/25 v2.8a biblatex bibliography style (PK/JW/AB)
historian.bbx    2010/08/22 v0.4 historian bibliography style
historian.cbx    2010/08/22 v0.4 historian citation style
biblatex.cfg
 english.lbx    2013/11/25 v2.8a biblatex localization (PK/JW/AB)

I'm using version 1.8 of biber.

I hope your older set-up can use this solution, but it seems that the abbreviate option was introduced in version 0.9c, which is exactly one minor release after the version of biblatex the biblatex-historian package claims to have been tested against.

If it does not work, you might(!) still have a solution, however. If you are using a TeX Live distribution, you can download the 2.8a version from sourceforge and the appropriate version of biber and update your installation. tds.zip files are extremely easy to install, just unzip at the base of your texmf tree, refresh the database, and you're good to go. However, I would sandbox the new installation until you are certain that biblatex-historian works with the newer form of biblatex before you remove the older one.

If you are leery of updating a setup that otherwise works for you, there are still options. One of the least invasive choices would be to add the following to the preamble:

\DefineBibliographyStrings{english}{ibidem = {ibid\adddot}}

which, as you can see, forces the use of 'ibid.' for the english language option (and thus is not american-specific). This is a good idea when you only need to make the change to one or two files.

Alternatively, you could make your own version of english.lbx and make the changes you want to it so it works (better) with Turabian requirements. E.g., you can locate line

ibidem           = {{ibidem}{ibid\adddot}},

in english.lbx and change it to

ibidem           = {{ibid\adddot}{ibid\adddot}},

This simply defines the ibidem string to only know the abbreviated form. The advantage of this solution is that one changed file can be used for multiple documents if placed in a smart location (such as what the command kpsewhich --var-value TEXMFHOME returns; in my case that's ~/texmf, which means I would put the english.lbx file in ~/texmf/tex/latex/biblatex/lbx/). It is important to note that this file will be selected before the one that ships with biblatex, which might not be what you want. As is so often the case, it is worth taking some time to think about what your long-term needs are and then act accordingly.

As a largely irrelevant aside: Note that American English does not 'have' only an 'ibid.' form: the period following the 'd' is a suspension mark, which marks that the word is abbreviated after the 'd' [i.e., the rest of the word is 'suspended']. 'Ibid.' is merely a common abbreviation for 'ibidem', which is a Latin adverb. Suspension marks, one of many forms of abbreviation in use way back when, are also why pedants might insist that we should use 'Dr' rather than 'Dr.', or that 'St.' is fine for 'street' but not for 'saint' since the abbreviation of 'doctor' and 'saint' comes from in-between the first and final letters and thus the dot incorrectly marks what is being suspended. Luckily pedants don't usually get their way..!

share|improve this answer
    
Regarding your last idea: It would even suffice to put \DefineBibliographyStrings{english}{ibidem = {ibid\adddot}} in the preamble: No hassling around with .lbx files etc. –  moewe Feb 24 at 6:58
    
@moewe -- Very true. I added some comments about the relative advantages of a 'local' versus 'global' fix along those lines. I still think a real solution will be an updated version of biblatex-historian... –  jon Feb 24 at 7:29
    
@jon -- Thank you very much, that is great. I honestly didn't know that historian was that old. I am using TexLive 2013 with biblatex 2.8, so I honestly don't know why this setup works for me and not for anyone else? It might be that historian is no longer needed. It is basically Turabian's version of the Chicago style manual, so I'll go look for a more up to date style that is being updated, if one exists. Thanks again for your help! –  Paul Feb 24 at 19:01
    
@Paul -- Glad it helps. Curious it works for you, but I'm not sure when the \SetCiteCommand was taken out of standard biblatex. On a different note, I think for biblatex, your best bet besides historian is biblatex-chicago, which is more actively developed; but, as I'm sure you know, the two specifications are not identical. –  jon Feb 24 at 19:19
    
@jon -- Yeah, I'm not sure either. I thought that biblatex 2.8 was the most up to date (other than the github repo), so maybe there is something still lying around in my setup. I'll check out the chicago one. it might be that I can tinker with it to get what I need. Thanks for the suggestion! –  Paul Feb 25 at 20:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.