Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using texlive 2013, and just ran the following command to update the packages.

sudo ./tlmgr update  -all

After it finished, I tried to compile tex documents that uses tikz package as the following MWE shows:

 \documentclass{article}
 \usepackage{tikz}
 \begin{document}
      aaaa
 \end{document}

Then pdflatex complains; it said:

 (/usr/local/texlive/2013/texmf-dist/tex/latex/pgf/utilities/pgfrcs.sty
 (/usr/local/texlive/2013/texmf-dist/tex/generic/pgf/utilities/pgfutil-common.tex
 ! I can't find file `pgfutil-common-lists.tex'.
 l.556 \input pgfutil-common-lists.tex

The problem is that, pgfutil-common-lists.tex is indeed in the directory:

 /usr/local/texlive/2013/texmf-dist/tex/generic/pgf/utilities/

Why is that? pdflatex should be able to find it, right? I even download the pgf package again, and replace the pgf directory in

 /usr/local/texlive/2013/texmf-dist/tex/generic/

Nothing changed at all........... Any idea? Thank you for your critics.

%=====================================================================

Then followed the comments, I type the following command in the terminal:

  1. sudo mktexlsr gives me command not found;
  2. mktexlsr gives me:

    mktexlsr: /usr/local/texlive/2013/../texmf-local: directory not writable. Skipping... mktexlsr: /usr/local/texlive/2013/texmf-config: directory not writable. Skipping... mktexlsr: /usr/local/texlive/2013/texmf-dist: directory not writable. Skipping... mktexlsr: /usr/local/texlive/2013/texmf-var: directory not writable. Skipping... mktexlsr: Done;

  3. Forkpsewhich pgfutil-common-lists.tex, nothing pops up.

share|improve this question
1  
run sudo mktexlsr and then kpsewhich pgfutil-common-lists.tex. Is there any output? By the way: I have no problem with TL2013 –  Herbert Mar 1 at 8:34

1 Answer 1

up vote 5 down vote accepted

It looks like that your path setting is wrong. Try once

export PATH=/usr/local/texlive/2013/bin/x86_64-linux:~/bin:$PATH

change x86_64 if you do not have a 64 bit system. Then run again sudo mktexlsr If it works then add to your local .bashrc:

export PATH=/usr/local/texlive/2013/bin/x86_64-linux:~/bin:$PATH
export MANPATH=/usr/local/texlive/2013/texmf-dist/doc/man:$MANPATH
export INFOPATH=/usr/local/texlive/2013/texmf-dist/doc/info:$INFOPATH
share|improve this answer
    
Thank you genious! I can compile tex files now :) –  Melon Tomato Mar 1 at 9:02
1  
you should accept an answer if it helped. Otherwise it will be counted as unanswered. –  Herbert Mar 1 at 9:05
    
I click the checkmark for your answer. Am I right? 0_0 –  Melon Tomato Mar 1 at 9:14
1  
@MelonTomato Yes, this worked. You know, this is exactly the way you are supposed to thank someone. :) The check mark is more important than Thank you. –  henry Mar 21 at 14:02
    
Yeah, I got it :) ^______________^ –  Melon Tomato Mar 23 at 5:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.