Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to create a document where citations follow the authoryear styling and bibliography follows the apa.

\documentclass{article}
\usepackage[american]{babel}
\usepackage[style=apa,backend=biber]{biblatex}
\ExecuteBibliographyOptions{maxnames=99}
\usepackage{csquotes}
 \DeclareLanguageMapping{american}{american-apa}
\usepackage{filecontents}

\begin{filecontents}{test.bib} 
@article{citation01,
Author = {LastName1, FirstName1 and LastName2, FirstName2 and LastName3, FirstName3 and LastName4, FirstName4 and LastName5, FirstName5 and LastName6, FirstName6 and LastName7, FirstName7 and LastName8, FirstName8},
Journal = {A journal name},
Number = {3},
Pages = {22--38},
Title = {A Title name},
Volume = {4},
Year = {2011}}
 @article{citation02,
Author = {LastName1, FirstName1 and LastName2, FirstName2 and LastName3, FirstName3 and LastName4, FirstName4 and LastName5, FirstName5 and LastName6, FirstName6 and LastName7, FirstName7 and LastName8, FirstName8},
Journal = {A journal name2},
Number = {3},
Pages = {22--38},
Title = {A Title name2},
Volume = {4},
Year = {2011}}

\end{filecontents}

\bibliography{test.bib}

\begin{document}

\textcite{citation01} and \textcite{citation02}.

\printbibliography

\end{document}

The output of the above file is:output

1) The full author list is not generated at the bibliography section.

2)

  • One option I tried was changing maxcitenames (setting it to 1).
  • Another option was using citestyle (=authoryear) and bibstyle (=apa) while loading.

Both of them failed.

Citation desired would be

LastName1 et al. (2011a) and LastName1 et al. (2011b)

and bibliography would include the full author list.

Any help is much appreciated!

share|improve this question
    
So you want to use APA style package to conflict with what the APA style guide says about author lists? –  Seamus Apr 21 '11 at 20:39
    
@Seamus Well many people require APA style in spirit, not letter. –  Alan Munn Apr 21 '11 at 21:10
add comment

1 Answer

From the biblatax-apa manual: (p.6)

The \maxprtauth commands returns the number of author/editor names which are printed. APA style defaults to 7. You can reset this after loading biblatex with, for example, \renewcommand{\maxprtauth}{25} if you really want to fully print all author list references in certain contexts (for example in a CV where you are an author in position 8 ...)

So the solution to your problem is to add

\renewcommand{\maxprtauth}{99}

to your document.

You should be aware that the format that biblatex-apa uses is the one required by the APA.

share|improve this answer
    
this solves the bibliography limitation! any workaround about the citations, aka make them look like authoryear ? –  gkotsis Apr 21 '11 at 23:49
    
@gkotsis On your test document, I get the et al. as well. Do you not? –  Alan Munn Apr 21 '11 at 23:52
    
nope, I am getting: “A Title name” (2011a) and “A Title name2” (2011b). –  gkotsis Apr 21 '11 at 23:55
    
@gkotsis Are you using the latest versions of biblatex and biblatex-apa? –  Alan Munn Apr 22 '11 at 3:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.