Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

The command for using the lato light font is given to be

\fontseries{l}\selectfont

but this command produces no change to my document when compiled with pdflatex.

I would like to use the light version of Lato as the default font for my entire document. How can I achieve this?

Thanks!

share|improve this question
2  
Is it an .otf or .ttf font? Use xelatex and see How do I use an OpenType font with my LaTeX document? –  Werner Mar 4 at 5:49
    
When are you issuing that command? Make sure you issue it after \begin{document}. –  cfr Mar 4 at 13:47

2 Answers 2

up vote 5 down vote accepted

As you say you're compiling with pdflatex, I assume you're using the lato package, so you can just set the default weight \mddefault to light:

\documentclass{article}

\usepackage[default]{lato}

\usepackage{lipsum}% for dummy text

\renewcommand{\mddefault}{l}% switch default weight to light

\begin{document}

\section{Title}

\lipsum

\end{document}
share|improve this answer

On the other hand, if you have Lato.ttf or Lato.otf installed and want to use them, here is a way. Use xelatex or lualatex for compiling the following code.

\documentclass{article}
\usepackage{fontspec}
\setmainfont[Ligatures=TeX]{Lato Light}
\usepackage{blindtext}

\begin{document}
\Blinddocument
\end{document}

enter image description here

If you don't have Lato installed, download a free version from fontsquirrel and install.

share|improve this answer
    
Very useful link to fontsquirrel. –  Thruston Mar 4 at 10:46
    
thank you! i'd really rather use pdflatex though. unless, is there a good way to enable small caps in lualatex? –  calben Mar 4 at 14:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.