Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

The legend box is covering parts of the graph (even though I removed the borders). How do I make the legend box transparent?

enter image description here

share|improve this question
add comment

1 Answer 1

up vote 11 down vote accepted

You can add fill=none to the legend style key as in this approach.

\documentclass[11pt]{article}
\usepackage[T1]{fontenc}
\usepackage{pgfplots}

\pgfplotsset{compat=1.9}

\begin{document}
  \begin{tikzpicture}
    \begin{axis}[
      legend style={fill=none}
    ]
      \addplot {x};
      \addlegendentry{$x$};
    \end{axis}
  \end{tikzpicture}
\end{document}

enter image description here

share|improve this answer
    
Repositioning the legend or decrease of its font size could also be an option. –  Thorsten Donig Mar 4 at 16:33
    
Thank you, works like a charm. No need to reposition or decrease font size now! –  user3218615 Mar 4 at 16:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.