Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In some French words when the circumflex is used over the i, there is no dot on the i. When I try to do it as described in "A Guide to Latex" the dot appears and the circumflex is too high. How do I fix this?

share|improve this question
    
Use \"\i as here: en.wikibooks.org/wiki/LaTeX/Special_Characters –  Paul Gessler Mar 8 at 23:42
    
BTW: Welcome to TeX.SX! –  Paul Gessler Mar 8 at 23:43
    
Can you show a minimal example of code? What does the guide you mention say? –  egreg Mar 8 at 23:44
1  
@PaulGessler - Did you mean to write \^i? –  Mico Mar 8 at 23:47
4  
We really need an MWE to say anything useful here. Presumably the OP is not using Computer Modern else the problem wouldn't occur in this form. Or if the OP is using it, something else is configured oddly. Either way, without the code we can only guess. –  cfr Mar 9 at 0:03

2 Answers 2

Just to demonstrate:

\documentclass{article}
\newcommand{\mytest}{%
  \^{a} \^{e} \^{i} \^{o} \^{u} \^{w} \^{y}\par
  \textit{\^{a} \^{e} \^{i} \^{o} \^{u} \^{w} \^{y}}\par
  \textsc{\^{a} \^{e} \^{i} \^{o} \^{u} \^{w} \^{y}}\par
  \^{A} \^{E} \^{I} \^{O} \^{U} \^{W} \^{Y}\par
  $\hat{i} \hat{\imath}$}

\begin{document}

\fontencoding{OT1}\selectfont

\verb|OT1|:

\mytest

\fontencoding{T1}\selectfont

\verb|T1|:

\mytest

\end{document}

will produce:

Circumflex accents everywhere...

Note that using T1 not only improves the placement of the accent, it also supports copy-and-paste for the first five characters. To see this, try copy-and-pasting the generated text. You will find that only the first five characters in the lines using T1 paste correctly. The others will decompose into separate circumflexs and letters.

This does not work for the final two characters, ŵ and ŷ, because these are not included in the T1 encoding. However, even in these cases, the accent placement is improved.

To actually use T1 in your documents, you should use

\usepackage[T1]{fontenc}

rather than the above code. I didn't do that because I wanted to demonstrate both OT1 and T1 in a single document.

As LaRiFaRi and Sean Allred point out, using

\usepackage[utf8]{inputenc}

or switching to XeLaTeX or LuaLaTeX lets you input the accented characters directly. (I use the inputenc option but they all work.)

â ê î ô û ŵ ŷ
share|improve this answer

Have you tried some of this? It's more a comment and I will delete it, when you show an MWE:

% arara: pdflatex

\documentclass{article}

\usepackage[utf8]{inputenc} % to insert the character directly by copy paste or as ^+i typed on your keyboard
\usepackage[T1]{fontenc} % to lower the accent

\begin{document}
î % direct with utf8
 \^i % LaTeX command
\end{document}

Make sure, to save your .tex-file encoded as utf8.

enter image description here

Edit: As Sean mentioned below in comment, the possibility exists, to use TeX-engines which support utf8 directly. If you are interested (and it's the way I do it), it would look like this:

% arara: lualatex

\documentclass{article}
\usepackage{luatextra}

\begin{document}
î % direct with utf8
 \^i % LaTeX command
\end{document}  
share|improve this answer
2  
Note with the Unicode option: more modern engines (notably xetex and luatex, called as xelatex and lualatex, respectively) don't need the inputenc or fontenc packages and can work with Unicode directly. –  Sean Allred Mar 9 at 0:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.