Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using the bigfoot package to generate two styles of footnotes, which I signal using either the normal \footnote or my new \footnoteB. FootnoteB uses alphabetical numbering but the count is reset each page (\MakePerPage); nowhere do I have even close to 26 of them on a single page. Here's what I've got in the preamble:

\usepackage{bigfoot}
\DeclareNewFootnote[para]{B}[alph]
\DeclareNewFootnote{default}

\usepackage{perpage}
\MakePerPage{footnoteB}
\renewcommand{\thefootnoteB}{\emph{\alph{footnoteB}}}

Most of the time it works fine. However, every so often when I'm compiling it will hit a footnoteB (not necessarily the same one every time) and come up with the 'counter too large' error, which shouldn't be possible for the reasons above. Sometimes I've been able to fix this by removing and then adding back in the perpage package, but the compiling seems a bit stuck this time around (after deleting aux files and trying again, etc.).

Why is it having this issue (of sometimes trying to number continuously) despite the \MakePerPage in the preamble, and how can I get it back on track?

share|improve this question
    
It would help for debugging if you provided a complete but minimal example (or see here). It may be difficult in this case, but it is usually even more difficult to solve if others have to create a difficult-to-create example themselves. As a workaround in the meantime, it is possible that the alphalph package would solve your pseudo-problem. –  jon Mar 10 at 14:39

2 Answers 2

In the first run it is not known, on which pages the footnotes go. Thus it might happen, that a footnote exceeds the 26 letters. You can try package alphalph to allow higher values for the footnote counter:

\usepackage{alphalph}
\renewcommand{\thefootnoteB}{\emph{\alphalph{\value{footnoteB}}}}
share|improve this answer
    
I've compiled this document successfully several times in the past, and I know that there's a maximum of around 10 on any given page. However, I have used alphalph in the past (just to get it to compile a working version when this issue has come up before and I need the text). Doing this has shown that it is in fact numbering continuously rather than restarting each page, but I don't know why the MakePerPage line is suddenly no longer functioning? I should add that when trying to use alphalph this time it still hits 'counter too large'. There's clearly something really not working right! –  Erika Mar 10 at 14:47
    
@Erika: The "perpage" feature needs more than one LaTeX run. –  Heiko Oberdiek Mar 10 at 14:52
    
Yes, I've been running it repeatedly (since that's usually my first fix). –  Erika Mar 10 at 14:54
    
OK, it seems to be working now, thanks. Is it because it requires to be able to count up past 26 on the first run before MakePerPage "kicks in", even though there aren't more than 26 footnotes on any single page in the final version? (Just want to make sure I understand sort of what happened--still not sure why it worked before, then stopped!) –  Erika Mar 10 at 15:02
    
@Erika: Yes. Package perpage writes additional label into the .aux file for the page numbers that are available in the next LaTeX run. –  Heiko Oberdiek Mar 10 at 15:07

Heiko already provided a solution (use the alphalph package); I'll add a quote from section 1.6. of the footmisc (sic!) documentation which refers to constraints of the package's symbol option. symbol can handle at most 16 footnotes per page, so it is likely that its problematic behaviour also applies to your example using alph (which can handle 26 footnotes per page).

When executing the perpage option, the package often allocates footnotes to the wrong pages, only to correct itself on a later run (having warned the user of the need for the later run with a 'Label(s) may have changed' message). In these circumstances the symbol option is prone to producing LaTeX errors, which stop processing, and confound automatic generation procedures.

share|improve this answer
    
Misusing comment: Would be nice, if you would add an anwer or two to Using KOMA-Script packages with other classes. With your insight perhaps something about scrbase? I could only write about \newcaptionname etc. and link to How to change the name of document elements like "Figure", "Contents", "Bibliography" etc.?. –  Speravir Mar 14 at 0:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.