Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This question already has an answer here:

Using this tex on TeXworks, I get an error. The code is an output from pandoc converting from markdown to tex.

I checked if I have all the packages with TeX Live Utility. I found the followings.

  1. When I check fontenc I found that I have greek-fontenc package.
  2. I am not able find lmodern and fixltx2e
  3. For inputenc, I have greek-inputenc
  4. I am not able find longtable in TeX Live Utility
  5. I have all other packages.

Now my question is how to install packages which I could not find it in TeX Live Utility?

I know this is a newbie question, but I appreciate your help.

Thanks in advance.

====

Error

fontenc.sty
100
I can't find file `ecrm1000'.
<*> ...ljfour; mag:=1; nonstopmode; input ecrm1000

Please type another input file name
! Emergency stop.
<*> ...ljfour; mag:=1; nonstopmode; input ecrm1000

Transcript written on mfput.log.
grep: ecrm1000.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ecrm1000' failed to make ecrm1000.tfm.
kpathsea: Appending font creation commands to missfont.log.

! Font T1/cmr/m/n/10=ecrm1000 at 10.0pt not loadable: Metric (TFM) file not fou
nd.
<to be read again> 
                   relax 
l.100 \fontencoding\encodingdefault\selectfont
share|improve this question

marked as duplicate by David Carlisle, Sean Allred, Speravir, Jesse, Adam Liter Mar 11 at 1:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Please post a Minimal Working Example of code which people can compile (or fail to compile) to reproduce the problem. What you've posted doesn't make it clear what the source of the problem is. I suspect that you have loaded fontenc with option T1 but that the cm-super fonts are either not available or not found for some reason. You could load a different font if you have one installed. For example, \usepackage{lmodern} might work. But it is kind of hard without seeing the code or knowing really anything about what you have installed or not. –  cfr Mar 10 at 23:23
    
What TeX distribution are you using? –  egreg Mar 10 at 23:33
    
typing ecrm1000 into the above search box shows lots of solutions to this problem tex.stackexchange.com/search?q=ecrm1000 –  David Carlisle Mar 10 at 23:49
    
note that the packages that you mention fontenc fixltx2e inputenc and longtable are all part of the core latex distribution not contributed additions. If you have latex, you have them already. –  David Carlisle Mar 11 at 0:13
    

1 Answer 1

I need to run sudo tlmgr install ec in the terminal. It works fine now. Thanks for your comments.

share|improve this answer
    
Note that you seem to have installed a very minimal subset of TeX Live's packages. Unless you are short of disk space or have a very slow connection, I recommended installing a more complete set as it will make your life a lot easier! If you are not short of disk space, in fact, I would recommend just installing the full version. This is especially good if you are relatively new to TeX as it helps to rule out weird errors or strange output due to missing packages. (TL doesn't contain everything but it contains most.) –  cfr Mar 11 at 0:20
    
How much disk space will be needed for full package installation? –  shin Mar 11 at 11:48
    
If you run the installer, it should tell you how much space is required for the scheme or collections you choose. So if full requires too much space, you can customise things and maybe choose medium or tetex instead. –  cfr Mar 11 at 16:25
    
Could you tell me how to run the installer? Do you mean TeX Live? –  shin Mar 12 at 22:21
    
Yes, TeX Live. Details are at tug.org/texlive. –  cfr Mar 12 at 23:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.