Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using this code to produce a wide table, but the caption in top is still in two column format.I used \caption package but it affects all of my figures captions and never solve the problem.

    \documentclass[prb,twocolumn,preprintnumbers,amsmath,amssymb]{revtex4}
    \usepackage{graphicx}
    \usepackage{booktabs}
    \usepackage{enumitem}
    \usepackage{tabularx}
    \usepackage{epsfig}
    \usepackage{amsmath,amscd}
    \usepackage{psfrag}
    \setlength\paperheight{11in}
    \usepackage[dvipdfm]{hyperref}
    \usepackage{amsmath,amscd}
    \usepackage{psfrag}


    \begin{table}[p]
    \caption{Plots of average power dissipated $\overline P$ vs the amplitude of second         harmonic $H_{ac2}$ for different values of the relative phase $\theta$, while $m=3$,  $\alpha=0.05$ and $H_{ac1}=2 H_1$.} 
    \centering
    \begin{tabularx}{\textwidth}{|X|X|X|}
    \multicolumn{3}{>{\centering\setlength\hsize{3\hsize} }X}{\boldmath$m=3$\unboldmath   ,       \boldmath$\alpha=0.05$\unboldmath , \boldmath$H_{ac1}=2H_1$\unboldmath}\\ \hline
    \includegraphics[height=1.7 in,width=2.3 in]{t21.eps} & \includegraphics[height=1.7 in,width=2.3 in]{t22.eps} & \includegraphics[height=1.7 in,width=2.3 in]{t23.eps}\\ \hline
    \includegraphics[height=1.7 in,width=2.3 in]{t24.eps} & \includegraphics[height=1.7 in,width=2.3 in]{t25.eps} & \includegraphics[height=1.7 in,width=2.3 in]{t26.eps}\\ \hline
    \end{tabularx}
    \end{table}
share|improve this question
    
Not directly related to your main question, but possibly of some use for improving the code and the look of the table: (i) Since you're setting the width of the tabularx environment to \textwidth, there's no point in specifying \centering. (ii) You can probably dispense with the \hline instructions as well as the vertical bars that separate the cells, i.e., I'd write \begin{tabularx}{\textwidth}{@{}XXX@{}}. –  Mico Mar 12 at 13:12
add comment

1 Answer 1

In a twocolumn text the table (and figure) environment only covers one column by default. The starred versions, table* and figure* cover both columns, so you want

\begin{table*}
..
\end{table*}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.