Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

For some reason, inclusion of the TikZ package in a document seems to change the page size: the bottom of the page is slightly shorter if TikZ is included. A minimal example is

\documentclass{article}
\usepackage{tikz}
\begin{document}
Hi, there!
\end{document}

I'm compiling using pdflatex, from TeX Live 2013 (pdfTeX 3.1415926-2.5-1.40.14 (TeX Live 2013)). I assume that it won't make much of a difference when printing, except maybe if the page is centered. In that case, using TikZ would shift the contents of the entire page downwards a bit...

share|improve this question
2  
How do you know where the bottom of the page is if this is the only content on the page? –  percusse Mar 14 at 11:53
3  
Having the pdf viewer open, and recompiling with and without \usepackage{tikz} shows the page size changing. Also, the distance from the bottom of the page to the page number changes. –  Michel Mar 14 at 11:55
1  
@Michael Rather than relying on your browser, you could use a tool such as pdfinfo, which will tell you exactly what the page dimensions are. –  Marc van Dongen Mar 14 at 12:10
    
Ah that gave me the hint to fix it. Using tikz, the page size changes from A4 to letter ... weird! –  Michel Mar 14 at 12:20

1 Answer 1

up vote 5 down vote accepted

Using \documentclass[a4paper]{article} seems to fix it. Without this, tikz changes the page size to letter!

share|improve this answer
    
Odd. I get the same. I cannot recall reading anything about this feature in the TikZ manual. I'd consider this a bug. –  Marc van Dongen Mar 14 at 12:39
    
Same here. But with \documentclass{scrartcl} I get A4 (my TeXLive default setting) in either case. –  AlexG Mar 14 at 13:02
    
@AlexG That's because scrartcl has a4paper as default, while article has letterpaper. Which means that if \documentclass{article} compiles with a4paper means that you have configured that before in the Latex instalation (or the compiler). I can't tell you more than that, and I'm not sure this is even true :S –  Manuel Mar 14 at 14:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.