Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Provided the following tex document using classicthesis, produces an error. How can I use direct input of special characters in \section in classicthesis?

I do not want to write e.g. \~{n} in the text, as it is not readable as easily as writing ñ.

\documentclass[10pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}

\usepackage[ngerman]{babel}
\usepackage[nochapters]{classicthesis}

\begin{document}
    \section{umlauts å à É Ü }
    text
\end{document}

The error is:

! Argument of \@firstofone has an extra }.
<inserted text> 
                \par 
l.9     \section{umlauts å à É Ü }

!  ==> Fatal error occurred, no output PDF file produced!
share|improve this question
    
\usepackage[pdfspacing]{classicthesis} –  Johannes_B Mar 17 at 9:59

1 Answer 1

up vote 4 down vote accepted

The standard setup of classicthesis uses soul for spacing small caps; add the pdfspacing options that uses microtype features:

\documentclass[10pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}

\usepackage[ngerman]{babel}
\usepackage[nochapters,pdfspacing]{classicthesis}

\begin{document}

\section{umlauts å à É Ü}

text

\end{document}

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.