Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've almost figured out how to cite a multi-volume book (as per my other question). I've separated it into 3 entities - and then used Set to put it into bibliography.

@Book{Boncompagni_2_vol,
  author="Boncompagni, Baldassarre",
  title="Scritti di Leonardo Pisano matematico del secolo decimoterzo.",
  address="Roma", 
  publisher="Tipografia delle scienze matematiche e fisiche",
  date={1857/1862},
  volumes = {2},
  note="(in Lat.)"
}
@Book{Boncompagni_vol_1,
  volume = {I},
  title="Leonardi Pisani, Liber Abbaci = Il Liber Abbaci di Leonardo Pisano.",
  date={1857},
  pagetotal={459},
}
@Book{Boncompagni_vol_2,
  volume={II},
  title= "Leonardi Pisani Practica geometriae ed opuscoli = La Practica Geometriae di Leonardo Pisano; Opuscoli di Leonardo Pisano.",
  date={1862},
  pagetotal={283},
}

@Set{Boncompagni_collection,
  entryset={Boncompagni_2_vol, Boncompagni_vol_1, Boncompagni_vol_2},
}

However, the problem is that now I have 4 references showing up - 3 originals and 1 set. I've used the \nocite{*} to always show all references.

Is there a way to hide only 3 of those references while printing everything else?

EDIT: Well it seems that by using @Set I automatically get all the individual entries hidden. So this question itself is wrong. But it still applies if the @Set is not present.

share|improve this question
    
I suppose that the conventions are probably different in your field, but in the social sciences where I work, I think most people(/editors/journals) would prefer that volumes published separately and in separate years be referenced to separate entries in the bibliography (somewhat similarly to how articles by different authors compiled into a book are cited -- one entry per article that you reference, no entry for the book as a whole). "Make sure this is what you want" is my message, I guess. –  Aaron Apr 26 '11 at 2:20
add comment

2 Answers

up vote 7 down vote accepted

Aussuming that you are using the biblatex package there are several ways of hiding entries in the bibliography:

  • To exclude a certain entry just use options = {skipbib=true}

    @Book{Boncompagni_2_vol,
    author="Boncompagni, Baldassarre",
    title="Scritti di Leonardo Pisano matematico del secolo decimoterzo.",
    address="Roma", 
    publisher="Tipografia delle scienze matematiche e fisiche",
    date={1857/1862},
    volumes = {2},
    note="(in Lat.)",
    options = {skipbib=true}
    }
    
  • You can also hide certain types of entries using specifying nottype or type in \printbibliography

    \printbibliography[nottype=online,title={Printed Sources}] % shows all entries excluding @online
    \printbibliography[type=online,title={Online Sources}] % shows only @online entries
    

There are many other ways biblatex can display bibliography entries. To see more examples have a look at http://dante.ctan.org/tex-archive/macros/latex/contrib/biblatex/doc/examples/

share|improve this answer
    
Thanks. How do I indicate that the type is "online"? –  drozzy Apr 26 '11 at 18:26
    
By using the actual @online type. Of course, you shouldn't change @book to @online to achieve that. You could do something similar with book or set types. –  Mikael Öhman Apr 26 '11 at 19:13
    
@drozzy This was just an example for the usage of type. In your example you should write \printbibliography[type=book] if you only want to display entries of the @book type. The @online type I mentioned above is just another type biblatex supports. It is used for online ressources. There is a list of all entry types in the biblatex manual from page 6 on. –  Thorsten Apr 27 '11 at 6:59
    
You know what's weird? When I use @Set - the Set itself shows up - but others do not. I didn't even need to use any of your suggestions... I just never noticed that @Set hides the individual entries. Does that seem right? –  drozzy Apr 27 '11 at 12:53
1  
Yes, if an entry is a set member and the set is cited, then it's not listed as a stand-alone entry. This applies only within a refsection and the behaviour is reset between refsections. See the biblatex manual 3.10.5. –  PLK Apr 27 '11 at 16:06
add comment

You can include the field options = {skipbib=true}, for the entries you don't want printed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.