Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have (supposedly) successfully installed xypic and am attempting to draw some diagrams. Everything is compiling just fine, but no matter what I do I cannot get the heads of the arrows to appear. All that shows up is the base of the arrow. For instance,

\begin{xy}
{\ar (0,0)*+{A}; (25,0)*+{A}};
\end{xy}

shows no arrow head.

share|improve this question
1  
Are you sure this is not an artifact of your viewer? What does the arrow look like if you open the PDF in Adobe Reader? –  Alan Munn Apr 25 '11 at 23:27
    
Thank you for your responses. I tried both of these already and it's still not including the arrowheads. I was thinking I might have place some of the files in the wrong directory. For instance, I couldn't come up with a natural place to put the Metafont (.mf) files in my ~/Library/texmf directory. Any suggestions? –  Brian Apr 26 '11 at 1:13
    
Since you're using a Mac, why did you have to install xypic in the first place? It should be part of your distribution. Maybe you should remove everything you installed in ~/Library/texmf and try it again. Your sample code works fine for me on a Mac, without having installed anything other than a full MacTeX. –  Alan Munn Apr 26 '11 at 1:45
    
It worked, thank you! –  Brian Apr 27 '11 at 3:59
    
@Jasper: if would be good if you would post that comment as an answer, additionally. –  Stefan Kottwitz May 6 '11 at 21:22

2 Answers 2

Use \usepackage[all,dvips]{xy} or \usepackage[all,pdftex]{xy} in the preamble according to whether you compile the diagram via latex+dvips+ps2pdf or pdflatex.

Also try updating your packages; sometimes there is a bug in one or two packages that would be fixed after the update.

share|improve this answer

I had this problem, and the dvips/pdftex fix didn't work for me. However, I eventually got it working by making sure I included \usepackage{amsfonts, amsmath, amssymb} in my preamble. Worth a try :)

share|improve this answer
1  
Welcome to TeX.sx! Your question won't be seen by many people here, so it would be best to repost it as a fresh question. Follow-up questions like this are more than welcome! Please use the "Ask Question" link for your new question; there you can link to this question to provide the background. –  Marco Daniel May 1 '12 at 10:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.