Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using biblatex with the following command:

\usepackage[backend=biber,style=authoryear-comp,
      bibstyle=authoryear,citestyle=authoryear-comp]{biblatex}

Now when I do a \textcite I sometimes get the following output:

Smit and John Doe, 2011

And in the bibliography

Smit, Peter and John Doe (May 2011). “Using

I find this ugly. How can I get the citation to be:

Smit and Doe, 2011

And the bibliography to be

Smit, Peter and Doe, John (May 2011). “Using

share|improve this question
add comment

2 Answers

up vote 8 down vote accepted

It is possible that \textcite will result in citations like Smit and John Doe, 2011 (including Does first name) because biblatex since v1.4 will fully disambiguate individual author names and name lists. Just see my example.

The Month appearing in addition to the year is actually a built-in feature of biblatex. Just use the date field instead of year, and conform to the required format. (Details may be found in section 2.3.8 of the documentation.)

For the reordering of names, I prefer the form \DeclareNameAlias{sortname}{last-first}. See Guidelines for customizing biblatex styles ("Bibliography -- order of first names and last names") for details.

\documentclass{article}

\usepackage[style=authoryear-comp,backend=biber]{biblatex}

\DeclareNameAlias{sortname}{last-first}

\begin{filecontents}{\jobname.bib}
@misc{S11x,
  author = {Smit, Peter and Doe, Jane},
  date = {2011},
  title = {Me and Jane},
}
@misc{S11y,
  author = {Smit, Peter and Doe, John},
  date = {2011},
  title = {Me and John},
}
@misc{S11z,
  author = {Smit, Peter and McGee, Bobby},
  date = {2011-05},
  title = {Me and Bobby McGee},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\nocite{*}

\begin{document}

\textcite{S11x}

\textcite{S11y}

\textcite{S11z}

\printbibliography

\end{document}

EDIT: Name disambiguation only works with biber as backend. Replace biber with bibtex8 in my example and see what happens. ;-)

share|improve this answer
    
Thanks a lot! This was indeed my problem. I had a certain bib entry with Doe, J and an entry with Doe, John. Fixing that solved my problem. About the month, I don't mind that one being there at all. –  Peter Smit Apr 27 '11 at 16:45
add comment

You don't need to use multiple bibstyle and citestyle commands if you are using the same format for both. So your command to load biblatex should be:

\usepackage[backend=biber,style=authoryear-comp]{biblatex}

(Since the authoryear-comp and authoryear bbx files are the same, there's no need to have separate bibstyle and citestyle specifications in this case.)

Your citations should show up as you request with the standard authoryear-comp format. If only certain items show up incorrectly, then this is likely a problem with how the .bib record itself is entered. If after comparing a .bib file record that works with one that doesn't, you are still having problems with this, you should edit your question showing the actual record from your .bib file that causes the problem.

With respect to the ordering of names, add the following to your preamble:

\DeclareNameAlias{last-first/first-last}{last-first}

With respect to having the Month appear in the date field in the bibliography, this is quite unorthodox. Are you sure you want to do this? I'm sure it's possible, but it might require some work.

share|improve this answer
    
Thanks for the tips. Actually, when you add the month field to the bib file, it will be included automatically. For the citation, I tried it now with an empty tex file, and it seems the same commands give me now only last names. Are there any packages that could interfere with biblatex? –  Peter Smit Apr 27 '11 at 16:41
    
A, no packages, but lockstep's answer was spot on. Thanks for the help anyway! –  Peter Smit Apr 27 '11 at 16:46
1  
@Peter: You should still accept @Alan's advice with regard to using multiple style options. –  lockstep Apr 27 '11 at 18:09
    
I switched to BibLaTeX just today and these information are priceless – especially the last \DeclareNameAlias. Thank you. –  Harold Cavendish Oct 15 '11 at 20:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.