Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

After upgrading to the latest version of TikZ/PGF I cannot access, using texdoc, the newer version of the documentation. When I invoke texdoc tikz it tries to open the version that used to reside in:

~/Library/texmf/doc/generic/pgf/pgfmanual.pdf

(corresponding to 2.10CVS). Somehow I cannot find a way to tell texdoc to open the right version which is located in:

/usr/local/texlive/2013/texmf-dist/doc/generic/pgf/pgfmanual.pdf

A temporary workaround I use is to have a symbolic link from the former location to the latter. However, this is really ugly solution... I don't remember how I managed to tell texdoc to override the shipped documentation back when I manually installed the CVS version; thus I cannot simply undo it.

Edit:

@AndrewSwann: The output of texdoc -l tikz is:

1 /Users/username/Library/texmf/doc/generic/pgf/pgfmanual.pdf
2 /usr/local/texlive/2013/texmf-dist/doc/generic/pgf/pgfmanual.pdf

and the list go on... My question can be also stated: How can I remove 1 and make 2 the first one?

share|improve this question
    
texdoc -l will list results and let you choose one –  Andrew Swann Mar 25 at 14:55
    
@egreg: If I do it, then texdoc complain that it cannot find the file at all. –  Dror Mar 25 at 15:10
    
Not the case for me :( I remember I had to do something special to tell texdoc to open the 2.10CVS version of the doc (when I updated to it manually). But I cannot recall what was the process. –  Dror Mar 25 at 15:24
    
Same two lines as in the edit. Note that I changed the file that is merely a symlink. –  Dror Mar 25 at 15:25
    
@egreg: if file in $HOME is removed then texdoc doesn't find anything. –  Dror Mar 25 at 15:46

2 Answers 2

up vote 5 down vote accepted

The personal tree rooted in $TEXMFHOME (~/texmf/ on GNU/Linux systems, ~/Library/texmf/ on Mac OS X with MacTeX), should never have a ls-R file at the top; this is the setting of TEXMF in texmf.cnf:

TEXMF = {$TEXMFCONFIG,$TEXMFVAR,$TEXMFHOME,!!$TEXMFSYSCONFIG,!!$TEXMFSYSVAR,!!$TEXMFLOCAL,!!$TEXMFDIST}

The absence of !! in front of $TEXMFHOME means that a ls-R file is not needed in the personal tree as well as in the “config” and ”var” secondary trees. However, creating it will make kpathsea use it.

In those trees one is supposed to have only a few things, so directly browsing the file system is not a costly operation. And it makes easier managing the personal tree, too, because you don't need mktexlsr after changing it.

So, remove ~/Library/texmf/ls-R and be happy. Of course, remove (or rename) the old manual.

share|improve this answer

To remove the CVS version of TikZ installed in your $TEXMFHOME (here, ~/Library/texmf/), you may use the following command (in a Terminal):

find ~/Library/texmf -iname pgf -exec rm -fr {} \; -print -prune
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.